Strange sputtering

I have an 08 YZ450F with JD kit, MRD exhaust, Vortex ignition and CP 13:1 piston installed. Bike used to run perfectly, but now it has started to act strange every now and then. It seems to sputter when I am in the air and giving it some more throttle (not fast really) and sometimes it doesn`t seem to rev up as cleanly as it should. It is actually very hard to even make bog. I really have to sap the throttle from idle to max as fast as I can to make it bog.

I tried using fresh fuel, took carb appart and cleaned everything with compressed air, but still nothing. Though I have to note that there were some dirt particles on the bottom of the bowl. Probably because the boot wasn`t tightened enough. At the moment I can only think of it has something to do with dirt getting inside. The boot was poorly tightened for about 4 hours.

I really hope it turns out to be something more simple and cheap then worn internals.

Drain your fuel out of your float bowl 17 mm wrench , and go from there

Obviously I allready did that when I used compressed air to clean the carb.

Did you take all the jets out and look at them? Sometimes compressed air will just jam a piece of sand etc further up into the jet. Does it do it with the throttle closed? When you first get on the throttle, or wide open?

I did not remove the jets. The bike seems to run all good, but the main problem is sputterin / hesitation once airborne or so does it seem.

check the ignition - maybe replace back to stock to see if the Vortex is faulty?

Check your AP timing.


I had made a similiar thread somewhere in January. About sputtering and not running smoothly when throttle is between 1/8 and 2/3.

The problem seemed to fade away and come up again every now and then.

After messing with needle, pilot, ignition (had Vortex for a while), sparkplugs etc. I finally found the problem. It happened to be the JD red needle.

I tried the needle pretty much in every position. I got it running almost good, but sill there was some hesitation and/or sputtering. I now popped in the stock needle in stock position and it runs smoothly again. Problem solved.

Not trying to show JD as a bad product, as there are like 50 people who are 100% happy with it, but I happened to be the 51.

For information I am situated at sea level ( like 300-500ft) and temperature is about 70-90F.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now