Jump to content
Sign in to follow this  

Dynojet kit installed but something is not right ?

Recommended Posts

Did the 3x3 airbox mod, stock jets 142.5, 22.5, opened up stock pipe. fuel screw 3.5 turns out, and installed the Dynojet needle-had to use the stock (big) spring...the one that came with the kit would'nt fit. It was alot skinnier that the stock and kept folding over when I tried to replace the cap on the carb. I did install the small DJ spring though. Anyway, when the bike is at low RPMs it hesitates when I gas it.ie If i'm going 45 mph in 5th gear and snap open the throttle the motor almost cuts out for a second then it kicks in and I get the power. Also, maybe I'm being greedy but it doesn't feel as fast as I thought it would. Did I do something wrong???

Share this post


Link to post
Share on other sites

Is it the right DJ kit for your bike? I installed one for a friend of mine, and it ran like crap. I scratched my head, took it apart, put it back together, for about an hour before we realized that the kit was for a Suzuki 4x4 quad. Dennis Kirk had sent the wrong jet kit :).

Share this post


Link to post
Share on other sites

the needle is 4th clip from top right?picture in instructions is wrong.something doesnt sound right about the kit.the dj spring looks identical to the stock slide spring.

Share this post


Link to post
Share on other sites

Yes, the clip is in the fourth from the top. The box said it was for a suzuki DRZ 400 S. When i put the needle in in was slightly angled from the pressure of the small spring, I had to move the whole assemly around until I found the small hole in the bottom of the carb. But it wasn't difficult to get back in. When I assembled the needle i went by the directions in the box. washer, white nylon washer, clip, washer, small spring and then the white plastic "cap" with the o-ring on it. It's not really idling great either, it kinda varies in RPMs while idling.

Share this post


Link to post
Share on other sites

The needle being slightly angled as it comes out of the slide is fine and normal as long as it makes it cleanly into place when you install. Be sure the plastic retainer with the o-ring is firmly seated in the slide. It's possible to have it holding everything in place without being pushed all the way down. When I installed mine I gave it one final push with some needle nose pliers just to make sure, and it kinda 'popped' in another 1/8" or so.

Share this post


Link to post
Share on other sites

Or possibly it is simply the air fule screw. 3 turns out sounds like a lot. Try playing with that first.

Share this post


Link to post
Share on other sites

Or possibly it is simply the air fule screw. 3 turns out sounds like a lot. Try playing with that first.

that setting isnt guess!!!!! :)

Share this post


Link to post
Share on other sites

You have to use the Dynojet main jets. The needle is tapered for their jets...the stock jet will be WAY too big!

IF you install the DynoJet kit...or anything else for that matter.....install the complete kit...not just the parts you want.

By the way, I also installed the kit and it ran like crap. I shimmed the stock needle .5mm and turned the air mixture out a bit and I'm using the stock Main Jet. Runs like a bat out of hell and still gets decent mileage!

I hope this helps.

Share this post


Link to post
Share on other sites

You have to use the Dynojet main jets. The needle is tapered for their jets...the stock jet will be WAY too big!

IF you install the DynoJet kit...or anything else for that matter.....install the complete kit...not just the parts you want.

By the way, I also installed the kit and it ran like crap. I shimmed the stock needle .5mm and turned the air mixture out a bit and I'm using the stock Main Jet. Runs like a bat out of hell and still gets decent mileage!

oh for [@#$%&*!] sakes!!!not that again!ive been over this a million times!there mainjets are ones they just make.it has nothing to do with the needle taper!

why would you spout off bad information?just for the sake of it?there are plenty of people using my set up with awsome results.sometimes there are install issues that always get solved.

just becuase you couldnt install the kit correctly doesnt mean it doesnt work. :)

Share this post


Link to post
Share on other sites

Eddie,

I heard that the dynojet main jets have custom ported, and polished holes in them, and are far superior to anything else? :):D :D Any truth to that?

Share this post


Link to post
Share on other sites

I know exactly what youre talking about with the cap in the slide, I double checked it before i installed the whole slide and it was propery seated all the way in. Fuel screw is 3.5 out but maybe that is too much...or not enough. I live in Florida and the air is very humid 80-100% most of the time, would that matter much though? Maybe i'll try rejetting with a 140 and 25. 2.5 turns out. would using the stock mainspring matter?

Share this post


Link to post
Share on other sites

Burned

The picture shows it forth position from the bottom. This is not correct? If I remember correctly I'm at the fourth from the bottom now. The bike started an idled and reved fine but I have not been able to ride yet. So are we talking fourth from the top or the bottom?

Share this post


Link to post
Share on other sites

Eddie,

I heard that the dynojet main jets have custom ported, and polished holes in them, and are far superior to anything else? Any truth to that?

lmao mike! :Damazing what sales pitches do.

Share this post


Link to post
Share on other sites

The picture shows it forth position from the bottom. This is not correct? If I remember correctly I'm at the fourth from the bottom now. The bike started an idled and reved fine but I have not been able to ride yet. So are we talking fourth from the top or the bottom?

4th from top.picture is wrong.

Share this post


Link to post
Share on other sites

bchptrl

i would also check to make sure the slide moves freely up and down and that the diaphram is seated in the groove.

Share this post


Link to post
Share on other sites

I just got thru putting a DJ kit in a friends 03Z400S and it rips :D per burned's info :D by the way Thanks! :D

I Noticed that when I put the slide back on top of the carb that there was a 1/2 circle discolorion towards the frt of the diapharm so I put my finger on the high part of the diaphram and to my surprise the discolorion matched when push down on seal witch meant that the thing had been pinched from the factory and the slide was not opening all the way since purchased new in 1-03 maybe this has happened to you or not? :)

I've seen those polished & ported Jets that came in the kit and there's nothing great or spl. about them :D if you like them so much put some thread thru them and made a neckless out of them if you can get them around your a$$ :D

just playing :D (NOT) :D

Share this post


Link to post
Share on other sites

lol Ed!

sorry guys,dont mean to come off as crazy.dont mind helping any body here.just seems to be a few doubters still.part of the game.no big deal.im ok now! :)

Share this post


Link to post
Share on other sites

Z4You,

I thought I laid the sarcasm on thick enough, you know that was a joke about the port, and polish thing right? :D:):D :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×