electric starter button issues - 06 450

I went riding in the pouring rain today, then i noticed i heard my starter motor turning over every now and then. I would switch the bike off in gear pull in the clutch and the bike would start up.. kinda like a party trick. I then ripped the headlight cowl off and disconnected the switch on the bars...

is this "short" quite common?

anybody else have/had this issue?

whats the cure?

I went riding in the pouring rain today, then i noticed i heard my starter motor turning over every now and then. I would switch the bike off in gear pull in the clutch and the bike would start up.. kinda like a party trick. I then ripped the headlight cowl off and disconnected the switch on the bars...

is this "short" quite common?

anybody else have/had this issue?

whats the cure?

The cure is to go over your harness and clean up any bad connections, shorts, or splices. They put the plug in connections back together with conductive grease to keep it working good.

My pan was to open it up, give it a good going over with some WD40 and take it from there.

Im going to be stripping down the bike and giving the whole bike a good going over... had a nice couple of months of riding.. time for some real maintenance...

A quick way to check the starter button is to use the kill switch. Simply unplug the starter from behind the number plate and plug in the kill switch where the starter goes. If it starts and runs good, then you know the starter button is bad. This is good to remember out on the trail. Then take apart the starter button to check for corrosion, broken spring, etc. I had similar problem on my '05 during a parade lap at a race. Bike started running really bad, starter motor running, all kinds of weird things happening for such a minor fix.

Same thing happened to me... It was the start button.

Simica's plan is a good method to use if the start button WILL NOT start the bike... but in your case I would just unplug the start button and use kick start for 1/2 day or something and see if your bike is still trying to start itself while it's running.

I would put a 95% chance it's just your button. It's happened to me more than once.:crazy:

It was exactly that. I plugged out the button and it was not running the starter anymore..

I opened up the button and it was very wet inside. Ill give it a good going over though with some wd40

Does this LSP switch have a connector compatible with the WR harness or do you have to splice the wires?

Does this LSP switch have a connector compatible with the WR harness or do you have to splice the wires?

You have to splice the wires.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now