Jump to content
Sign in to follow this  

Some questions about my XRL

Recommended Posts

I purchased a complete '85 XR600R motor on ebay over the winter. I had originally intended to use it as a parts motor to add a kicker to my '97 XR650L.

The top end was trashed, but the bottom end was good, so I decided to rebuild it as a spare. I had it bored to 100mm, installed a JE 10.5:1 Piston, and a hotcam in a '90s head. I'm using the L stator and electrics.

I've put about 500 miles on it so far and it's been running good. It doesn't burn oil or leak, but I do have a few questions that hopefully someone can help me out with:

1) It's got loads of compression, without the release, I doubt I could kick it over. But after it sat for about a week or so, I could kick it through without the release. After it warmed up it was back to normal. I'm assuming this is because oil drains and the rings don't seal as well after a while. Is this correct and is it normal?

2) I am running the stock L carb with a 55 pilot and a 162 main and a factory needle all the way up. This worked pretty well except at 1/8 throttle it is definitely lean. Is upping the pilot the appropriate thing to do there?

Share this post


Link to post
Share on other sites

Hmmm, i suppose i could shim the needle a bit and see if that helps. I've also ordered a #58 pilot and a #165 main, so hopefully i'll be able to get it going better.

I have one more question I forgot to ask. When the bike is cold or if I shut it off, it only takes 1 or 2 kicks to start. But, if it stalls it's very hard to start. I've tried a lot of the starting tips i've seen here, but I can't seem to find a routine that helps.

Could this be related to my jetting problems?

Share this post


Link to post
Share on other sites
Hmmm, i suppose i could shim the needle a bit and see if that helps. I've also ordered a #58 pilot and a #165 main, so hopefully i'll be able to get it going better.

I have one more question I forgot to ask. When the bike is cold or if I shut it off, it only takes 1 or 2 kicks to start. But, if it stalls it's very hard to start. I've tried a lot of the starting tips i've seen here, but I can't seem to find a routine that helps.

Could this be related to my jetting problems?

You have a kicker on your 650L? I'd try the new jets you bought and see how it reacts. Jetting is never easy in special conditions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×