Help needed with fuel screw

I just bought a ZipTy fuel screw. I removed the stock screw and made sure that the sping, washer and o-ring all came out with it. The problem is when I screwed the ZipTy in it only turns in 2 to 2-1/2 turns from fully out. The instruction say it should be 8-11 and then back out 1-1/2 turns. What might be keeping it from seating? I'm ok with pulling the carb but if there is something easy I should be looking at then I'm all for it.

8 to 11 turns? That can't be right. I'm pretty sure mine is only 3 or 4 turns max. Are you sure you aren't feeling the resistance of the spring and with a little pressure it will go in another turn?

If you added a new O-ring for the new screw, but did not remove the old one, that could be your problem.

It's also possible you have the wrong screw. There were two lengths, one for the earlier FCR on the 400, and another for the FCR-MX on later bikes. Check the length of the old and new needles from the threads to the tip.

I made sure that the old o-ring came out with the old screw and placing the old and ZipTy screws side by side the lengths above the threaded section is identical. I also tried installing it without the o-ring, washer and spring to see if it was the spring pressure I was feeling but I got the same results - only 2 to 2-1/2 turns in and the screw stops. I didn't count the turns it took to remove the old screw, only the number of turns I thought it was taking to bottom it, so I don't know if this is a new or pre-existing condition.

Send it back. The same thing happened to me. Didnt screw in as far as the instructions indicated, was difficult to turn, when turning out 2 turns it seemed as if it would fall out. I even used the oem spring, same deal.

I'll screw the OEM screw in and count the turns - if it goes in as it should then I'll exchange the ZipTy screw. Davcon, I assume yours was a one-off issue and that your replacement ZipTy went in fine?

I have a MSR one and it works fine. Might consider getting one of them.

My Zip Ty works fine, they will make it right.

It must have been a problem with the ZipTy fuel screw. I put a Tusk fuel screw in and had no problems with it and it only cost $12. Problem solved.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now