Jump to content
Sign in to follow this  

My blinkers are broken...help!!!

Recommended Posts

I was trying to hook up a relay to my horns and must have shorted something out...now my blinkers don't work. Did I short out a fuse? I checked the main fuse, headlight fuses, and my flasher unit.

Anyone have any ideas what I should check next?

Thanks,

Jimmy

Share this post


Link to post
Share on other sites

i just had a problem the other day with my blinkers too and i had found out that the ground wire had broke loose from the socket and had to solder them back on,

Share this post


Link to post
Share on other sites

Yeah I had that problem once as well. Easy fix, but all mine are out. I'm wondering if there's a fuse or something else I blew out.

Share this post


Link to post
Share on other sites

Have you got a circuit tester that you can use to trace where the power loss comes from? You would obviously have to have power going through the bike to do this.

Share this post


Link to post
Share on other sites
I checked the main fuse, headlight fuses, and my flasher unit.

Do any of the signal lights light up at all or are they dead?

How did you test the flasher?

Share this post


Link to post
Share on other sites

They are all dead. Im also wondering if it is the blinker switch...?

I just hooked up another flasher to test it. I have a thermal flasher in there, so I just tested it with the stock flasher.

Share this post


Link to post
Share on other sites

If it is the blinker switch there should be power going to the switch, which you can check with a circuit tester. Do you have one of these?

Share this post


Link to post
Share on other sites

if they're all dead, start by checking for voltage to the switch, if you've got voltage on at least one of the pins, then check to see if turning the switch right or left makes a connection.

If that makes good contact (minimal OHMs) then you gotta trace the wires to find the problem.

If there's no voltage going to the switch, you gotta trace the wires to find the problem.

Share this post


Link to post
Share on other sites

Fixed it!!! Thanks guys. It ended up being a broken wire going to the flasher. It was an extension I added on, so it shouldn't be a common problem.

Share this post


Link to post
Share on other sites

Good, one piece off advice, on anything with an engine, you should solder the connections, this is esp. important for lights and even more so for motorcycles, a bad brake light circuit can cost you much more than body damage.

Share this post


Link to post
Share on other sites
Good, one piece off advice, on anything with an engine, you should solder the connections, this is esp. important for lights and even more so for motorcycles, a bad brake light circuit can cost you much more than body damage.

GREAT advice that i have not followed. if i would have, it could have saved me many headaches.

remember, mac isn't a complete idiot cause some of the pieces are missing!! :busted:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×