86 kx250 starting problems

hi all, im new here & this has probarbly been mentioned in another thread but i havent seen it anywhere. I have just got myself a 86 kx250 which had starting problems when i got it, the bike has been stored for about 3-4 years, it will roll start fine but wont kick start. (you could kick it all day) it has about 130psi compression, has fuel as plug is wet (even put a iridium plug in it) pulled plug out & it has spark when kicking over, ive been as far as checking reed and they are fine... im not real familar with 2 strokes but any help would be appreciated. the person i got it off said he put has problems with it starting when hot when he use to ride it but started ok when cold but it wont even do that...

If it is just 130, then it is time to check the rings, piston, etc.

If it is just 130, then it is time to check the rings, piston, etc.

ok... thanks, what psi should they be???? seems to have a fair bit of comp when roll starting it, it locks the wheels up as im only a small person & have to sit right back on the seat to get the back wheel to turn...

Generally, if you can't kickstart it, but you can push start it, then that means a compression problem caused by a worn engine.

Generally, if you can't kickstart it, but you can push start it, then that means a compression problem caused by a worn engine.

ok thanks, even though its not what i wanted to hear...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now