Jump to content
Sign in to follow this  

Jetting help for a 05 250F

Recommended Posts

Hello all...

I have a 2005 Yamaha YZ250F. I live in the high desert of SoCal. It gets hot in the summer (mid 90's - 100+) and can get cold in the winter (50-70) with low humidity.

Anyhow, ever since I bought my bike (new in 05) my bike has always bogged and hesitated coming out of corners or when you slam the throttle. I have had the top end redone but never had the jets changed. Its still stock (main jet-182, jet needle clip pos-middle or 4th position, pilot jet-42, leak jet-90). Other than getting a 450 (which will be in a year or so) what can I do to fix my problem? It also "pops" when you let off the gas.

Any help will be greatly appreciated.

I did by the JDJetting kit but all it had was (2) needles and main jets.

Share this post


Link to post
Share on other sites

first off drop that 90 leak jet down to at least a 50. That 90 is wayy to big and is probably part of if not the whole problem. Have you done the O-ring mod to the accelerator linkage? If its popping when you let off the gas there are two possibilitys. One is that you have an exhaust leak in the headpipe or your jetting is too lean. Just my .02 :busted:

Share this post


Link to post
Share on other sites
first off drop that 90 leak jet down to at least a 50. That 90 is wayy to big and is probably part of if not the whole problem. Have you done the O-ring mod to the accelerator linkage? If its popping when you let off the gas there are two possibilitys. One is that you have an exhaust leak in the headpipe or your jetting is too lean. Just my .02 :busted:

Ill do that. Ive been reading that a lot of guys have gone to a 185 main jet. Im thinking about changing the MJ to a 185 and the LJ to a 50 or 60...

Thanks for the info. I appreciate it.

Share this post


Link to post
Share on other sites
Ill do that. Ive been reading that a lot of guys have gone to a 185 main jet. Im thinking about changing the MJ to a 185 and the LJ to a 50 or 60...

Thanks for the info. I appreciate it.

Yes we run a 185 for most tracks here as well when it get to 100 + degree temps we've had to drop down as far as a 175 though. In the winter we have had to go up as much as a 188. That was Eastern Wa and it was about 35 degrees. My son has alot of guts riding in that weather. There was a light dusting all around the track at the time too.

Share this post


Link to post
Share on other sites

I am have the same kind of issues on my 05 yz250f. I do not pop, but it seems like I am running lean. My pipe glows red if I sit for any bit of time. As far as the blog, try a quick shot 2, it has helped my bike a ton with power now. My leak jet is a 40, and my main is a 178 in western washington.

Share this post


Link to post
Share on other sites

I also live in the high desert (hesperia) and have a 2005 yz250f that i've owned since new. My bike has always had a low end bog and a little decceleration pop until I just recently installed a boyesen quickshot 2(got it for free) and got an adjustable fuel screw. Now the bog is almost gone, I want to try out a different leak jet though, and see if I notice anything.

What part of the desert are you from?

EDIT: just realized this thread is from september

Edited by MotoXRider43

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×