230 quad runner all messed up!

Suzuki

This is one of my quadrunners, this one was having an issue of staying started for more than 2 seconds and we figured there was something wrong with the carb.

I rebuilt the carb today and this is what its doing....really getting me mad

The only way it will start is to screw the idle screw all the way and using the primary choke..then rev it up turn off the choke and slowly bring the idle down with a screwdriver...then it either skyrockets with revving or it tries to idle nicely and stalls.

Sounds like an air leak but your real problem could be a bad or out of adjustment valve.

Sounds like an air leak but your real problem could be a bad or out of adjustment valve.

I belong to a camaro forum as well and decided to post it over there to some friends and they said the same thing...air leak...but where can there be a leak at on this model?

as far as I know there is a boot on each side of the carb and both are nice and snug.

sometimes you can see the carb tick to the side like its jerking, does that sound like an air leak? I dont know much about diagnosing these things... Ive had this quad new since I was 8 and it never had any issues.

heres a third video

broken needle screw! fixed.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now