blaster will not start

Yamaha

Ok so I looked around but couldn't really find a good answer to my ?. I have an old blaster that has good rings/compression, carb has been cleaned , tanks been checked, has spark, but it will not start. If i put alittle gas in the cylinder it will fire but dies right after starting. I have tried a different carb that I know is in working order and same result. reeds are brand new as well. Any ideas im out of them?

Maybe an air leak? Sounds like it is unable to pull the fuel into the crankcase & cylinder. if there is a bad enough crank seal (on the stator side) I guess it could be pulling enough air in from there instead of the carb. Is the intake boot in good shape?

the intake boot is in good shape, quad looks practically brand new, also has all new gaskets,

Sounds like it isn't getting fuel so I would focus my attention there.

Take off the float bowl cover and depress the float to make sure fuel comes out from the needle jet.

I thought that would be the case aswell, I tried putting a carb off my other blaster thinking that it was the problem and it was still doing the same exact thing.

Then look for a clogged petcock, pinched fuel line, etc before the carb

Wouldn't think that would be the case, the carb is getting fuel but the motor is not, like its not pulling gas in from the carb however I will check those just to make sure, thanks for the help!

You said it has good compression.....what was the reading you got? A 2 stroke won't start if compression is under 100 lbs

showed around 120

dirty needle valve isn't allowing fuel into float bowl.............

dirty needle valve isn't allowing fuel into float bowl.............

not likely with 2 separate carb's...

How about a restricted exhaust?

He claims that fuel flows freely to the carb so that rules out a clogged petcock or fuel line. Compression is OK for a Blaster and he gets spark so what else is left?

Did the 2nd carb work fine once you put it back on it's original quad?

yeah the 2nd carb came off a running blaster and when put back on the original it fired right over, I have checked everything I can think of and had a friend of mine who works for yamaha look at it and he couldn't figure it out either. Im clueless haha

Could it be a problem w/ the TORS?

Im having a simular problem on my blaster brand new bottom and top end new reeds ive tried 3 diffrent carbs but no fuel is getting to the plug someone help me please

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now