Jump to content
Sign in to follow this  

back firing

Recommended Posts

hey everyone i am new to tt. i have a 2004 crf250r had a valve job about a year and a half ago now and since the valve job only hvae rode it for about 4 hours. now i can not get it to run with out the choke on. once the choke is turned off it back fires like crazy while i am giving it gas and once i let off it dies. can not figure out what is going on. need help?

Share this post


Link to post
Share on other sites

sounds like your pilot jet is clogged and will only run on choke because it is richer.

Riding 4 times in 1.5 years theres a good chance the fuel gummed up the jets, clean the carb and all shall be good i say

  • Like 1

Share this post


Link to post
Share on other sites

You need to clean your carb out, there is probably some junk in the jets.

  • Like 1

Share this post


Link to post
Share on other sites

hey everyone i am new to tt. i have a 2004 crf250r had a valve job about a year and a half ago now and since the valve job only hvae rode it for about 4 hours. now i can not get it to run with out the choke on. once the choke is turned off it back fires like crazy while i am giving it gas and once i let off it dies. can not figure out what is going on. need help?

Share this post


Link to post
Share on other sites

could it have anything with my hot start cable not being fully screwed into the carb,my threads are stripped and don't know how to fix it.other tan just replacing it.thanks in advance for any information

Share this post


Link to post
Share on other sites

i hvae already gone through and cleaned the carb and it is still doing the same thing

Check out all your jets by taking them off the carb and looking through the hole to make sure there is light on the other end.  Those pin holes are so small, it's easy to gum them up, specially when it's been sitting for a while.  I have been working on a Tecumseh 10Hp these last few days, and the only way I was able to clean the jets out was by using a thin wire to run through the holes.

Share this post


Link to post
Share on other sites

just got rid of backfiring by recleaning carb and jets again. bike is cranking on 2nd or 3rd now however I just noticed tonight that my header was glowing red after a 5 min. cruse around neighborhood give in mind iv never rode the bike at night so maybe that's why iv never noticed it cause I always ride in day time or do I have a major problem and am just now seeing it.could any one give me some info on this subject,thanks by the way it is 05 crf 450r with a two brothers exhaust on it that I recently repacked with fmf muffler packing can someone help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...