Jump to content
Sign in to follow this  

Advice on 2009 te 250

Recommended Posts

Looking into buying a 2009 te 250 from the US. I understand that these are detuned, and need some wrenching to getyup:ride: .Does all parts to make this happen come with the bike? After all power has been restored(:moon:) does the efi have to be reprogramed in some way?

Anyone with the te 250 please answer:worthy:........

Share this post


Link to post
Share on other sites

Got mine at Bill's in Salem,OR .He did all the power up before it left at no charge. The bike comes with all the pieces to do it .Have a box full of junk that came off.

Share this post


Link to post
Share on other sites

I am talking to a pretty big dealer but it dosent really seem he knows much about his own bikes. have been talking to them a couple of times on the phone and havent really gotten a god impression This is what i wrote after they sold the TXC i said i would buy. They told me they just had the te 250s left

ok.... need a race bike. You dont sell this bike in race mode if i understand correctely.

I have seen this on the net but after talking to you guys, this is not correct?

Service Bulletin C004-2008 - FULL POWER KIT INSTALLATION PROCEDURES” for 2009 TE & SMR 250-310-450-510’s.

There are four pieces - 1) Lambda sensor plug 8000A7724, 2) Lambda sensor plug gasket 8000A7749, 3) Lambda sensor connector 8000A6750, 4) Air filter cage 800069549.

from what i have heard the bike goes in to race mode when you take the o2 sensor out and put the plug in.

After what i understand after talking with someone from your parts dep. i understand that the te you are selling dont come with the Arrow silencer and the efi has to be re-programed.

What will it cost to get the bike in race mode and not the dual sport?

And this is their answer:

Sorry for the delay. We just have the 2009 TE 250's left.

We don't get into the race parts at all

If they dident sell this bike at such a cheap price i would go somewhere else with my bike buy. Thats why i am seeking advice here.:moon:

Share this post


Link to post
Share on other sites

All those parts come in the crate with the bike.in the box with the battery @ mirrors and other misc stuff.

Share this post


Link to post
Share on other sites

Similar question, I had the dealer do the modifications mentioned above ( 1) Lambda sensor plug 8000A7724, 2) Lambda sensor plug gasket 8000A7749, 3) Lambda sensor connector 8000A6750, 4) Air filter cage 800069549) and they couldn't get it to idle so they removed the sensor plug, anyone experience this? They are trying figure it out, maybe some one here already has.

Is this related to the EFI question from wippersnapper?

Thanks!

Share this post


Link to post
Share on other sites

Sounds like the TPS is not set correctly. Need to get it on iBeat software.

Might want to pull the cat out of the pipe too.

I think most of the information for fitting the powerup parts is in the Shop Manual, which the dealer should have.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...