Jump to content
Sign in to follow this  

backfiing popping on low rpm deceleration

Recommended Posts

hey all

i got a 06 te 510 that popps and backfires:moon: during deceleration i put the summer version of jd jetting in but tested it during cold air i'm going to change to their winter jetting specs but was wondering is this a lean or rich condition cause my plug looks perfect and i sealed all exhaust seams with make a gasket. any help ....

Share this post


Link to post
Share on other sites

Its a sign of an air leak where the exhaust pipe joins the cylinder head. You can make your idle circut overly rich and mask the issue but that is not the fix and also causes other issues such as slowed throttle responce

Share this post


Link to post
Share on other sites

To all,

Upon further inspection i found a hole in the rubber of my carb intake boot so hopefully this was the problem....

Share this post


Link to post
Share on other sites

hole on intake side has no impact unless it is so big the air is not filtered.

If your exhaust is sealed OK then you are too lean on the pilot. Not a surprise given it is winter time. Try opening your fuel screw a half turn. If that doesn't do it then go up one on the pilot.

Share this post


Link to post
Share on other sites

the hole was after the carb but before the motor. must have been sucking some serious air as the hole was 1/2 in long and almost a 1/4 inch wide right where the rubber meets the metal brace at the motor. this must have been the problem waiting on a new one and let you know but check yours

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...