Jump to content
Sign in to follow this  

So this isnt in the FAQ..

Recommended Posts

I just did all the free mods, Leo Vince X3 pipe and header, JD jetting, Boyesen Quickshot 2 accelerator pump cover, boyesen power x wing and thats it.. So i just took it out and rode it in the 37 degree weather.. and sparks were coming out of the pipe not many but just some.. and also every once and a while flames would come out. it wouldnt really pop though.. Its a 2008 WR 250f.. Sorry.., if you read some of my other threads ive posted i worry alot.. probably too much.. But i'm just making sure thats normal and its jetted correctly.. Thanks so much

Share this post


Link to post
Share on other sites

That is typically a sign that you are too lean. Fatten up your jetting and see if it is better.

Share this post


Link to post
Share on other sites

Yes let it warm up a good bit before you get too worried about it. In those temps (the norm around here this time of year) our bikes take a little time to warm up. After warming it up good though you shouldnt have any poping going on anymore if so as KJ said fatten up your jetting. :moon:

Share this post


Link to post
Share on other sites

With all the changes you made to the bike did you change the jetting at all? It does sound like it could be a little lean, but the sparks could also have been from the new silencer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...