Jump to content
Sign in to follow this  

2007 kxf450 shifting issues?!?!?!

Recommended Posts

So my 07 is missing from first to second WAY too much. The rest of the shifting isnt really super smooth either. It doesn't miss from second up but seems to take a little more effort then it should? I'm thinking the end of the shift shaft is bent, maybe I landed on the shifter. Any other ideas?

Share this post


Link to post
Share on other sites

I have the same issue with my 07. As far as I know that's the design of the transmission that's to blame not the shifter. I have considered having the gears treated (read a while back about a process that essentially polishes the gears and makes for a better shifting motor) can't recall the name of the process, burnishing maybe? but it's like $400 so i'm hesitant to do it. Instead I went up 2 teeth (to a 52) in the rear and rarely use first anymore unless I really need grunt coming out of a corner or something. Whole different bike now and no more ghost shift hassles.

Share this post


Link to post
Share on other sites

there are only a few possibilities that could cause this problem and they all lie in a trans tear down and inspection, except 1. You can pull your RH covers off, remove your clutch basket and inspect your shifting star, keepers and return springs for any abnormalities. Such as wear in the 1-2 valleys in the star, flat spots on the roller of the detent spring or i have seen the bolt that holds the star to the shift drum loosen causing shifting woes, specificly 1 -2 shifts

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the post. This is the first time i've seen anyone actually explain what could be going on in there besides someone saying "that year of KX just has clunky shifting". I will definately act on this advice. I'll get a couple more rides in before winter is in full swing then crack it open and see what's going on.

Thanks again!

Share this post


Link to post
Share on other sites

Is it missing shifts or a hard shift, hard to get it to grab the next gear?

Share this post


Link to post
Share on other sites

From first to second it will sometimes miss and go to neutral. I don't think it's just me since i've never had that trouble on any other bike.

First gear on that bike is almost useless anyway i'm just getting better at clutching second if I need to crawl around a corner or something.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×