Jump to content
Sign in to follow this  

drz400s won't idle (after 3x3)

Recommended Posts

I performed air box mod on my 2001 drz400s. I installed dj needle and spring.

Then installed 25 pilot and 140 main. My bike didn't start. I turned off choke then bikes starts and idles until warm. I figgure too rich. I re-istalled 22.5 pilot, same thing. I put stock needle, mj 145, pilot 22.5 mix screw 2 turns

bike still won't idle when warm. Just currious what I could have messed up.

Why would my bike run too rich at idle. could a bad o-ring on idle screw make it run too rich. Thanx for any idvice

Share this post


Link to post
Share on other sites

Yes I have the vacuum line to the petcock. I have tried adjusting the idle screw, but it seems like it is too far rich. It will consistently idle cold (choke on or off) but once it warms up there is nothing I can do to get it to idle or restart. Bike ran before I took carb off and did airbox mod. don't know what I did to mess up idle circuit. Should idle with stock settings even with airbox mod.

Share this post


Link to post
Share on other sites

Thank you for advice. My oil does smell like fuel. So I know I have to change oil. But what should I do to avoid fuel in oil again? Was it just because I had it too rich and flooded originally? Petcock could have been let on prime?

Thanx again for your assistance, I hope they pay you well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×