Jump to content
Sign in to follow this  

Powervalve stuck open?

Recommended Posts

Ok so just did a fresh top end on my 98 YZ250. bike was running awesome through break in, i took it out this morning for a little trail riding and all was good until it started bogging, and a kind of stutter noise. I've done a little research and i think the power valve is stuck open. my question is how do i diagnose this, and what is the easiest fix for it, I'm leaving for a trip this weekend so a temp fix is fine. Also i had like a mile ride home could this have done any damage to the bike?

Share this post


Link to post
Share on other sites

If the PV is stuck open, your bike will still feel normal at high RPMs.

Are you certain you put everything back together correctly?

Share this post


Link to post
Share on other sites

I thought I had the same problem and it was to much silicone around my front pipe to cylinder connection. If you used silicone try a new/different silencer or re-pack your muffler as I had the same symptoms after a re-build.

Share this post


Link to post
Share on other sites

powervalve.jpg

so i took the cover off and all the linkage was loose so im pretty sure thats the problem, does this look like i put it all back together correctly?

Share this post


Link to post
Share on other sites

My pv stuck after a rebuild. Attempting to diagnose it by looking at the pv was futile, as it was very temperamental.

For this reason, I pulled the jug, disassembled the pv, cleaned it and never looked back. It didn't take that long and I've never had any issues since.

Don't try to short cut the process, pull the whole thing to bits and clean it properly. Another thing I learned the hard way :thumbsup:

Berg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×