Jump to content
Sign in to follow this  

Popping on decel, won't idle....

Recommended Posts

I have a 05 crf450x that I used to ride weekly until I went back to school to finish my degree. During this two year period I rarely ever rode my bike. For that last year my bike just sat in the garage. Now that I finished my degree I am anxious to start riding again but I have had nothing but problems with the bike for the past few months. Prior to my bikes sabbatical it ran flawless and I never had any issues.

1. The bike is impossible to start with the kick starter when cold

2. It wont idle anymore

3. Upon decel it pops/backfires

One problem that I created was leaving fuel in the carb (I always planned on riding so I assumed that it would not sit long). Knowing the effects of this, I completely cleaned out the carb and jets (after noticing the above issues). Nothing else has changed in the last year and now I can't get my bike to run properly again. Any ideas?

Share this post


Link to post
Share on other sites

Are you saying that even though I cleaned the pilot jet with carb cleaner, there may still be enough old fuel residual inside the jet to plug it, or at least reduce the flow enough to cause these issues? I guess what the heck, replacing the jet would be a cheap but labor intensive fix.

Share this post


Link to post
Share on other sites

Just do it.

And yes, it's hard to clean the PJ orifice sufficiently once it varnishes without damaging the PJ (i.e. sticking a wire through it and deforming the orifice). It's not labor intensive to replace, You can get to it through the 17mm cover in the bottom of the float bowl.

Edited by davidl9999
Can't spell... D'oh

Share this post


Link to post
Share on other sites

WOW. Amazing what a little extra fuel will do for ya. The PJ works great; second kick and it fired right up, idled and ran great without the backfiring. Thanks for the fast response.:thumbsup::banana::ride::ride:

Share this post


Link to post
Share on other sites

I know the problem is fixed but I just wanted to ask how much popping is normal on the X models...Mine is a 250X and pops on decel...I always just assumed it was the smog pump causing the popping....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×