Jump to content
Sign in to follow this  

performance cam HELP!

Recommended Posts

So i bought a performance camshaft for my 08 klx 110 its from fasterminis.com and its a Trial Bikes KLX110 Race Cam for Stock or Race Head is exactly what the title or whatever is but anyways i put it in and the motor ticked. there was no tick before. so i adjusted the valves multiple times and nothing so i took it out. while doing some research i found out you can get stiffer valve springs. well just got a set and put them in along with the cam and it still ticks i havent tried adjusting the valves yet but i was wondering if anyone has had these issuses also or how to fix it or whats going on please help im also going to try and look for some other forums

Share this post


Link to post
Share on other sites

Its gonna tick you valves are lifting alot higher and staying open longer. your gonna have more tick then a stock cam. should hear a bigger motor when you put a yx cam in it.

Share this post


Link to post
Share on other sites
So i bought a performance camshaft for my 08 klx 110 its from fasterminis.com and its a Trial Bikes KLX110 Race Cam for Stock or Race Head is exactly what the title or whatever is but anyways i put it in and the motor ticked. there was no tick before. so i adjusted the valves multiple times and nothing so i took it out. while doing some research i found out you can get stiffer valve springs. well just got a set and put them in along with the cam and it still ticks i havent tried adjusting the valves yet but i was wondering if anyone has had these issuses also or how to fix it or whats going on please help im also going to try and look for some other forums

You put in hd valve springs with the head on ?? How'd you do that ?

I know that TB stuff always seems to more noisy that other brands ..

Is the cam chain tension correct ?

Share this post


Link to post
Share on other sites

i never ran hd springs in my tb head and i had the yx cam. most aggressive cam you can stuff in that head. never had a problem with float

Share this post


Link to post
Share on other sites

well im just going to asume it clicks then and not worry but to put the valve spring in you are suppose to use a valve spring compressor i just used vise and a piece of tubing with the side cut out so i could put the retainers back in

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×