Jump to content
Sign in to follow this  

Missing clips :-(

Recommended Posts

well seems that I thew away the clips that came with my 94mm je piston ......

Now the question : will the original clips from the std piston work OK, or should I put the story on hold while I order a replacement set ?

Share this post


Link to post
Share on other sites

Order the replacements. It is never a good idea to reuse the clips even if they are the same.

Share this post


Link to post
Share on other sites
well seems that I thew away the clips that came with my 94mm je piston ......

Now the question : will the original clips from the std piston work OK, or should I put the story on hold while I order a replacement set ?

WAIT... DO NOT re use clips, nor clips from one brand to another.. Sucks, but a destroyed motor cuz the piston pin clip failed is a lot more time and money then waiting on a new set of clips.

Share this post


Link to post
Share on other sites

Not to worry - found them :thumbsup:

Did not want to reuse clips - just that it would have been faster and easier to get hold of a new set of OEM clips ..... did a bit of research and found that the JE and the OEM clips both same thickness 0.050 - so in theory it shouls have been just fine.

But luckily I found the original je's that came with the piston :ride:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×