Jump to content
Sign in to follow this  

Starter Issues???

Recommended Posts

Hi, i have a 04 KTM 525 EXC, and just recently my starter seems to be acting up... its like the starters teeth are not grabbing the flywheel in order to turn the engine over... if i tap it lightly with a wrench it grabs right away...a'la 78 camaro... :ride: ... i'm wonderin' if the starter is just worn out, if maybe its shifted a bit and i can just remove it and clean it and replace it, if its a sign of the brushes wearing, or if i might need shims... has anyone else experienced similar issues??? BTW the bike does have the 580 kit on it, with an e-line stator, and the big YUASA battery on it... juice is not an issue... any help would be greatly appreciated, as whacking at my bike to get it started is somewhat embarrassing ...:thumbsup:

Share this post


Link to post
Share on other sites

the 05s had an issue with bad heat treatment on the gear in the right side case, but Ive not heard of an 04 with the problem, unless you replaced the gear at some time and got a bad 05 part. There is a thread on KTMTALK about taking the starter apart and cleaning it when it got like yours and it then worked great again. So maybe its time to take yours apart and service it. OR maybe the auto decompressor is not adjusted right and not releasing enuf comp.

Share this post


Link to post
Share on other sites

it seems to be exhibiting the same problems as posted about the freewheel... thanks for you help! :thumbsup:

Share this post


Link to post
Share on other sites
the 05s had an issue with bad heat treatment on the gear in the right side case, but Ive not heard of an 04 with the problem, unless you replaced the gear at some time and got a bad 05 part. There is a thread on KTMTALK about taking the starter apart and cleaning it when it got like yours and it then worked great again. So maybe its time to take yours apart and service it. OR maybe the auto decompressor is not adjusted right and not releasing enuf comp.

Its the intermediate gear if its not engaging properly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×