Jump to content
Sign in to follow this  

fouling plugs what do think?

Recommended Posts

1982RM250 well the jetting couldnt get any more perfect last year. but i did a full rebuild on it and now it is a little rich. But the clutch side crank seal was the correct size double lip seal(not motorcycle specific). i am thinking the seal i bought is just not up to standards of a motorcycle specific seal. it went in fine, but may be a couple thousanths out of square. and my spark is not as hot as it should be' but the same as last year. it fouls plugs in about 5 minutes now and smokes with a sweet smell(not really bad). I already ordered a new oem seal for it. second opinions?? thanks

i am thinking its the crank seal. i just bought the correct size from a seal manufacturer, not from a bike parts store.

Share this post


Link to post
Share on other sites

that an interesting thought. i have had the crank seal problem so many time. but that makes sense. i wonder wich spot would be leaking. i did use some gasket sealer on the middle case gasket. ill look into that. thanks

Share this post


Link to post
Share on other sites

well i figured out i was just seeing the last leg of my cdi and stator going out. now their is no spark. no wonder it was acting all weird. the cdi has the red wire grounding on the inside. and their is zero resistance any way i test the stator. i have an older suzuki cdi, same wire set up, and the red wire is not soposed to be grounded.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×