Jump to content
Sign in to follow this  

07 150f runs with choke, not without

Recommended Posts

when i start it up with choke on, it idles good but when i take off the choke, it dies immediatly. The bike sat for about 9 months and had some gas in it. Just a carb cleaning or something worse?

Share this post


Link to post
Share on other sites

If it ran good before it sat then get rid of the old gas. You will need to pull the carb and clean it up and pay special attn to the pilot jet (it's probably plugged).

Share this post


Link to post
Share on other sites

Sounds like a simple carb cleaning. I doubt there is any major damage.

Share this post


Link to post
Share on other sites

so i ended up taking this out and checking everything and cleaning the carb jets. It was idling better but not perfect and also stuttering at higher revs. took it back apart and went to clean the fuel screw (or what seems to be a fuel screw) and this is what i see

utzll.jpg

This isnt a hex head, allan bolt, phillips or straight. It looks like a D shaped thing. Now on Bike bandit, it shows it as a 'screw set' but also has the spring and washer that you typically see accompanying a fuel screw.

What in the heck do i use to get this out?

Share this post


Link to post
Share on other sites

It is your fuel screw. Why they shaped it like that??? Probably to stop any adjustments. You can buy a "D shaped" socket for around 2 to 3 dollars. Try to spin it out with a small screwdriver. I couldn't get it to move. Good luck.

Share this post


Link to post
Share on other sites

could this be the reason for my studdering if its dirty in the actual hole?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×