Jump to content
Sign in to follow this  

PROBLEM WITH DR-Z!!!helP plz

Recommended Posts

Currently my bike have this habit of making back fire when i release my throttle when moving.after i increas my idling the back fire became louder.My setting is jd kit 155 and 22.5 as my country is mostly sea level. slip on lv pipe and 3x3 mod. Does this back fire means its time to do valve clearance? oR is there anyway for me to DIY the problem by tuning back the carb.?

do help plz.thank you

Share this post


Link to post
Share on other sites

Sound like it's lean , when letting off the throttle , main jet is not doing much.

Pilot jet or fuel screw needs a look at.

Share this post


Link to post
Share on other sites

Happened to mine twice last summer, same, backfiring started from no where.

First time, pilot was plugged off by a tiny tiny black spec

second time, carb-intake clamp had come loose.

Does it start up and idle the same or are you finding you have to use alot more choke to keep it running, and are you using the stock air screw?

With just a slip on and stock header I think I'd stay with the 155.

How many miles on the bike, you are the original owner?

Share this post


Link to post
Share on other sites

thx to those who replied.my bike is currently using pipercross air filter.the back fire came from the pipe and now i dont know how to adjust the fuel screw as i didnt change to keintech fuel screw.

Share this post


Link to post
Share on other sites

Didn't you adjust the screw when rejetting ?

Share this post


Link to post
Share on other sites
anyone know how to adjust the air and fuel ratio?

Running on a dyno with a wideband sensor and rejet

Share this post


Link to post
Share on other sites

ok did my valve clearance.bike feel much better.but the backfire is still there when deaccelerate.OH ya one more problem just came to burn my wallet.there is a leak somewhere at the lower block.super stress rite now.i dont know whether i ride my bike with sufficient eo inside or it is completely drain.

Share this post


Link to post
Share on other sites

The leak from the lower block might be coming from the front sprocket area and draining down. Check it out, it's a simple fix if it is from the front sprocket. HTH

Share this post


Link to post
Share on other sites

My DRZ also makes a popping sound out of the exhaust when i decelerate. Not sure if it is normal but I would appreciate insight as well. I dont know much about this stuff.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×