Jump to content
Sign in to follow this  

Magura Hydraulic Clutch problem

Recommended Posts

Hi, I received my magura hydraulic clutch kit for my 2010 crf250r today, fitted it, pulled the lever and oil squirts out the slave cylinder! Took it back off and found a small hole in the seal around the cable (picture below) which must have caught on something when feeding the cable through. Is this seal an oil seal? I want to find out as if its just a seal to keep dust out etc then there must be a problem with it and I can send it back.

Thanks

magura.jpg

Share this post


Link to post
Share on other sites

I had the exact same problem when i got one for my 02 cr250. The rubber part you see is just to keep dust out. There is an oil seal inside the slave cylinder. If you got it new call up magura. When i had the issue i called magura and they sent me a new slave cyl. free of charge. 2+ years later and no problems since. I was very happy with their customer service. :thumbsup:

Share this post


Link to post
Share on other sites

I bought the kit from the US but I live in the UK, can I just call up a magura dealer in the UK?

Share this post


Link to post
Share on other sites

http://www.venhill.co.uk/ are Magura suppliers in the UK but I'm not sure they'll service a warranty claim on parts bought from abroad. They're nice folks though, so give them a call.

Have you spoken to the original suppliers yet?

Share this post


Link to post
Share on other sites

I haven't yet as getting this sorted in the UK would be alot easier. Will contact him now anyway to see what he says.

Share this post


Link to post
Share on other sites
I bought the kit from the US but I live in the UK, can I just call up a magura dealer in the UK?

dunno, i didnt talk with a dealer i went straight to the cow.

maguras website no longer has a phone number listed on the site but they do have a contact form, you could try that.

Share this post


Link to post
Share on other sites

That accordian part is just a dust boot. The sealing is done with orings. If you tried to operate the lever without it completely attached to the bike, what you described can happen. Do not ask how I know. But once installed, and then bled properly, all becomes fine.

There is in internal spring that must be under tension, if it is not, it can leak.

Share this post


Link to post
Share on other sites
That accordian part is just a dust boot. The sealing is done with orings. If you tried to operate the lever without it completely attached to the bike, what you described can happen. Do not ask how I know. But once installed, and then bled properly, all becomes fine.

There is in internal spring that must be under tension, if it is not, it can leak.

You sir are a genius! Put it on the bike and bled it, and no leaks!:banana: Thanks alot!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×