Jump to content
Sign in to follow this  

CCM 404 won't start.

Recommended Posts

Hello all. I have a CCM 404DS (2004) with a starting problem that is really confusing me.

  • Battery is charged
  • Engine is turning over
  • Air is getting through
  • Fuel is getting through
  • There is a spark

BUT NO MATTER WHAT I DO, IT WON'T START!

This bike has the same engine and carb as a DRZ400E. It is a low mileage bike in excellent condition, being regularly serviced. Could it be an electrical problem? Could it be a problem with a part unique to CCM?

Has anyone experienced this before? Are there any CCM experts out there? I'm really struggling to find any answers! Maybe I should have bought a DRZ, there's loads about them out there!

Share this post


Link to post
Share on other sites

Check sidestand switch.

To eliminate every safety gizmo ,try to start it in neutral, clutch in , and sidestand up.

Share this post


Link to post
Share on other sites

Do you have compression?

Have you had the bike layed up or is it a problem that has got worse?

Is fuel getting to the cylinder?

I take it you know if you keep throttling it the pumper carb will flood the engine.

Share this post


Link to post
Share on other sites

I have had a few replies already and it's really appreciated guys cheers. Here are the answers to all your questions:

Carb clean...yes

Fresh fuel...yes

Healthy spark...yes

I will definately take the side stand switch out of the equation, just incase it's that.

Matt_rufus, I think you may be onto something...the spark plug is wet with fuel when I take it out...I'll check the float as soon as I can.

Compression is good.

Bike is ridden regularly. Advice about the pumper carb is appreciated and I am beggining to think the engine is flooded, but not from over throttling.

I'll keep you all posted, thanx again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×