Jump to content
Sign in to follow this  

two bros over the peg brake pedal sticking

Recommended Posts

hey guys hows everyone doin in the tt world, im hopin you can help me i bought the two bros over the peg brake pedal and after installin it when i hit the brakes it just jams into the peg and stick

Share this post


Link to post
Share on other sites

not sure on the design but you can figure it out.... go out and watch the motion, if you can figure out what its sticking on you should be able to figure a way to fix it, if its getting stuck between the foot peg and motor or swing arm try tightening the linkage are you on stock drums or have you upgraded to hydrolic disks, you could be low on fluid. someone will come along that has an over peg brake and will be able to help you more just thought i would try and help

Share this post


Link to post
Share on other sites

thanx for the fast reply it has drum brakes i shaved some metal off the bottom it looks lke its gunna work but i havnet been able to try it out yet

Share this post


Link to post
Share on other sites

maybe having pictures might be able to allow us to give you more feedback?

Share this post


Link to post
Share on other sites

My experiences with theses things ..., is that they never fit perfectly out of the pakage ..

I've had to re-form ( bend ) the arm so it clears everthing in it's path ..

I've found that if the brake pivot arm is bent back .., the arm will hit the kit starter and stop it from full travel -or- might cause it to stick on the way back up ..

I've seen em stick on the clutch cover right behind the kick starter too ..

I've also seen .., where the rear brake shoe pivot arm that fits thru the rear hub panel sticks ....

The rust + dirt build up on the pivot shaft will cause the pedal to stick in the down position . The only way to get it to return is to move the arm back by hand ..

To fix that .., you will need to remove the pivot arm , clean and re-grease the pivot arm and hub brake shoes plate .

Share this post


Link to post
Share on other sites

its prolly sticking under the clutch cover. mine seemed to work the best if i bent it out a little bit. also check to see that the arm that pulls the drum is moving freely. you could have it adjusted to far one way or another

Share this post


Link to post
Share on other sites
il check it out but it was stickin to the peg mount

:banana:..., I can't see how it would do this unless the peg mount is bent up really bad ..

Share this post


Link to post
Share on other sites

Wait a minute do you have an aftermarket peg mount? i believe that pedal doesnt work with a stock mount

Share this post


Link to post
Share on other sites

well my comps actin up i cant put up the pic . it looks like its catchin and the sprinf for that peg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×