Jump to content
Sign in to follow this  

Suzuki started a money pit!!

Recommended Posts

So I started rebuilding my ltz 400 and I figured I would post it on here just in case it could help somebody or if somebody has some tips I hope im uploading these pictures right.

SANY0014.jpg

I love a parts washer

SANY0004.jpg

SANY0009.jpg

SANY0007.jpg

SANY0010.jpg

SANY0013.jpg

Share this post


Link to post
Share on other sites

Got the frame powder coated started puting it all back together today. It looks great, probley will start on my stroker motor tommorrow.

SANY0023.jpg

SANY0024.jpg

SANY0025.jpg

SANY0026.jpg

SANY0027.jpg

SANY0028.jpg

SANY0029.jpg

SANY0030.jpg

SANY0031.jpg

Share this post


Link to post
Share on other sites

Dude that looks awesome. It looks like your doing a really good job and doing everything right.

Share this post


Link to post
Share on other sites

It has taken alot of time so far. Does anypne know what the loctite fix is? Do you have to do it on ltz400. Also does anyone on here need old ltz parts I have a bunch a would be willing to help someone out.

Share this post


Link to post
Share on other sites
It has taken alot of time so far. Does anypne know what the loctite fix is? Do you have to do it on ltz400. Also does anyone on here need old ltz parts I have a bunch a would be willing to help someone out.

Yeah i have an 03 ltz400 and need some parts. Heel guards, skid plates, etc. I need a lot of miscellaneous parts. What all do you have? Im sure we could work out a price for some stuff if i need it.

Share this post


Link to post
Share on other sites

It's coming along pretty good it looks like I'll help u work on it when I come home this time if u don't already have it done by then but we will def have to take out the pitbikes and do some riding and I might take out the 450 again before I rebuild it I'll bring the big rig home this time so we will have more time to ride and break stuff lol later

Share this post


Link to post
Share on other sites

DAMN!!!!!!!!! thats looking awesome. You sure are building this right.

What year is it btw?

Share this post


Link to post
Share on other sites

Started to put the motor together tonight got the valves in and thebottom end back together Ill get the cylinder and piston in soon and get the head on Its a 2007.

SANY0155.jpg

SANY0154.jpg

SANY0153.jpg

SANY0152.jpg

SANY0151.jpg

SANY0150.jpg

SANY0149.jpg

SANY0148.jpg

SANY0160.jpg

SANY0159.jpg

Share this post


Link to post
Share on other sites

So Ive been getting alot done I got my motor back together after having to shim the cams and trim my valve pockets on my piston to get all of my clerances correct. Got my carb In and put it on filled up my tank with av fuel and after I figured my starter would not even turn my motor over I hit the start button after about ten rotations It started up and Idled perfect and I couldnt resist revving It a bit It dosent even sound like a 400 It is bad and revs so quick. I still need to figure out my wire for my lights and a couple other things then its time for the first test drive.

SANY0167.jpg

SANY0169.jpg

SANY0170.jpg

SANY0171.jpg

SANY0172.jpg

SANY0173.jpg

SANY0174.jpg

SANY0175.jpg

SANY0176.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×