Jump to content
Sign in to follow this  

2010 FMF Q4 Slip on - stock exhaust clamp doesn't work.

Recommended Posts

Just got a new Q4 and the stock pipe clamp doesn't work, due to the stock pipe having a large O.D. than the new one(stock uses a steel wool mat in between the header and muffler pipes together increasing total size) Anyone happen to have a link of where I can get a clamp that works and/or school me on what would work? Thanks!

Share this post


Link to post
Share on other sites

Go to an auto parts place and ask for a T Bolt clamp there strong and stainless so they look like they belong... and obviously come in different sizes

Share this post


Link to post
Share on other sites
Generally, after market pipes don't use a clamp. If the end of the mid pipe isn't split lengthwise, it's not made for use with a clamp of any kind.

I installed a Q4 on my '08 450, and as Gray said, no clamp necessary.

BUT,

you should apply high temp silicone at the joint so it doesn't leak.

Share this post


Link to post
Share on other sites
I installed a Q4 on my '08 450, and as Gray said, no clamp necessary.

BUT,

you should apply high temp silicone at the joint so it doesn't leak.

Defiantly no clamp required.

Share this post


Link to post
Share on other sites

wow, no clamp, good to know guys. I have a tube of high temp copper rtv and will smear some of that on there...Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×