Jump to content
Sign in to follow this  

Question for riders with 22mm clamps....

Recommended Posts

Have got some 22mm clamps comming for my 2010 KX250F and after some setup info from experienced riders with these clamps or from riders who have used them before.

Whats the best fork position etc in your triple clamps to get the best out of these 22mm clamps?

Share this post


Link to post
Share on other sites

I run mine at the first line. Some people run them higher to avoid pushout, but that's what the 22 offset is for.

Share this post


Link to post
Share on other sites

do you have stock valving? i have an 09 with 22mm clamps and had my valving changed a few times and had to change the hight with difrent valving. so basically you need to test for yourself to see your prefrence. now i'm pretty close to the fork cap but i know its because of the valving i have now.

Share this post


Link to post
Share on other sites
do you have stock valving? i have an 09 with 22mm clamps and had my valving changed a few times and had to change the hight with difrent valving. so basically you need to test for yourself to see your prefrence. now i'm pretty close to the fork cap but i know its because of the valving i have now.

Yeah ive had it revalved twice, my main use for the bike is enduro. Had it softened up in the HS a little bit more last friday so its a bit softer than stock. Any tips or what indicators i should look out for that might require me to move the forks up or down from where i have it now with the stock clamps once i put the 22mm ones on?

Share this post


Link to post
Share on other sites

the general set up would be if you soften up the valving you would slid the tubes closer to the cap. but you can change that to tracks your riding like if it is low speed and tight slid the tubes up and if its fast slid them down. experiment a little so you know what it feels like.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

  • Similar Content

    • By Toms.abpg
      Just bought this bike and the pop on decel is horrible, looks like I’m gunna have to try a Tokyo mods remap. Anyone had success with this ?
    • By _Cloudy_
      Hi, I have just bought a kx250f, 2013 with a freshly rebuilt 2016 motor in it, this is my first time on these forums, anyways, I have also bought a lowering link to drop it 4 inches on the arse, I was wondering if anyone knows how much I should drop the forks? 
      I havent put the lowering link on yet. 
      Thanks.  
    • By Zach Miner
      Recently had issues with the original fcr carburator that was installed in my 2009 kx250f, tried jetting multiple time and different gas and the bike would only run with the choke ziptied out. Do I went ahead and purchased the lectron gen 2 4 stroke carburator kit, was kinda expensive and I was kind sceptical but after my first ride all I got to say is wow. The only adjustment I have done it set the idle, the bike runs amazing and feels as if there is more power than before. The kit came with a new throttle tube assembly and a g2 throttle tube with adjustable cams for throttle response. I highly recommend if you have a carburator on your four stroke and don't want to get a new dirtbike that is fuel injection then go the route of throwing out that junk fcr carburator and get a lectron gen 2 carburator for your old 4 stroke

    • By DirtbikeDon
      I own a 2012 Kx250F that I would like to make street legal if possible and I recently saw Rocky mountain I believe sells these battery packs that sit in the airbox for bikes without batteries that looks too good to be true and a headlight and turn signals like a conversion kit basically and I was curious as if anyone has had luck with those or if there junk it would be nice to make my bike street legal for short trips or just have lights for trail riding with friends that already do if possible any tips on converting it? 
    • By kylesmith_14
      The launch control only lights up when you first start up the bike when you try to use the launch control it doesnt light up at all ive tried 1st 2nd and neutral for 3+ seconds ive cleaned the connections and also cleaned the neutral saftey switch or gear selector and still no luck any help would be appreciated
×