Jump to content
Sign in to follow this  

Blowing smoke rings out off power valve vent tube

Recommended Posts

After trying to find an air leak, I put my 90 RM250 back together. Since it seemed lean and hunting on idle I wanted to go up on the pilot jet. None were available local, so using my jet drills, I made it 0.002" larger. The idle issue seemed better, but I discovered something new.

I finaly fired it up outside (at night) ran it around where I could see to get it up to tempature. I parked it under a big light to adjust the idle and noticed smoke from the front of the engine. On each pulse smoke would come out of the power valve vent tube (sometimes blowing perfect rings).

Before I put the pipe on I had made sure that the power valve adjuster was set right and using a flash light and wood dowel, made sure the valves moved freely.

I have never owned a 2T with a power valve before. When I ride it I hear a noise coming from that area (almost a rattle). The pipe springs amd mounts are secure, so I dont think its the pipe making the noise. Now I am wondering if the valve could be moving up and down or rattling in the bores.

When I bought the bike ($125 Craigslist) it had started to sieze at the exhaust ports. I cleaned up the cylinder and put a new topend on (2 hours now). Now I am wondering if there was damage done to the power valves, and if they are not working right, it is causing my idleing problems. Except for the idle the bike runs great, pulls good on the bottom and has plenty of power.

Is there anything I should look for?

Thanks for your help

Share this post


Link to post
Share on other sites

when i start my bike with choke on, smoke comes out of a plastic tube as well, i think thats normal but that might not be what your talking about

Share this post


Link to post
Share on other sites

No, this is with the choke off. I have a decent idle now (not perfect), this smoke coming out of the vent has me worried though.

Share this post


Link to post
Share on other sites

Some smoke out of the vent is normal. The valves rattling around is not. Did you take them apart and clean them when you did the top end?

Share this post


Link to post
Share on other sites

Sorry to say that I didn't, I wanted to get it together so I could ride (green sticker season). Are there anything I should look for when cleaning. It is my backup /trail bike and I would like it to be right.

Thanks

Share this post


Link to post
Share on other sites

Broken/worn slides and loose and worn parts. you'll be able to see when something isn't right when you pull the jug and actuate the powervalve by hand.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×