Jump to content
Sign in to follow this  

DR 350SE Blinker Not Blinking

Recommended Posts

I've purchased a new (to me) 99 SE. The previous owner had both rear blinkers and license plate light removed.

I re connected the blinkers and lp light and all lights on the bike work, but the signals do not blink.

Since all the bulbs are working, I am thinking I hooked up the rear signals wrong, and didnt ground them right.

Can somebody tell me if the rear lights are supposed to have the 2 wires from the chassis harness connect direct to the 2 wires that emit from the blinker? Or is the black wire on the chassis/blinker supposed to go to ground instead?

Thank you!

Share this post


Link to post
Share on other sites
I

Can somebody tell me if the rear lights are supposed to have the 2 wires from the chassis harness connect direct to the 2 wires that emit from the blinker? Or is the black wire on the chassis/blinker supposed to go to ground instead?

Thank you!

The two wires get plugged together..... NOT to chassis ground.

I'd be willing to bet your "turn signal relay" (flasher) is bad or it needs to have the connections cleaned where it plugs in to the harness .

I'm not sure about the '99 model but on the older models the relay is located under the headlight cowl on the left side.

It's a small black square relay mounted in a rubber holder.

This diagram may be of some help if you don't have one.

Save the pic to your desktop so you can zoom in on it

DR350Wiring.jpg?t=1268280700

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×