Jump to content
Sign in to follow this  

2004- locking up on decel.!!!

Recommended Posts

I just bought a 2004 RMZ250. Got it running good and then tried it out. When i hammer down through the gears then let off the gas, the rear end locks up and the motor dies. Then i kick it and it fires right back up. It has done it 2 or 3 times and dont know what on earth could be the issue. I have changed the oil and inspected the oil and it was clean, no metal shavings or anything.

Any suggestions?

Share this post


Link to post
Share on other sites

It sounds more like the engine is stalling, not locking up. I would bet that your problem is either a carb that needs to be cleaned out or jetted better. Or you need a new top end.

Granted, the idle could be set too low ~ so how well does it idle?

Share this post


Link to post
Share on other sites

Thanks for the response. I guess it is the engine locking up somehow. Today i started it and was letting it idle and it locked up. Kicked it again and it started again. It supposedly has a new top end and i cleaned the carb twice! It doesn't like die slowly, it sounds like it locks up, then its fine. Another thing i noticed, occasionally, the kick starter will lock up then free its self seconds later. That may be a decomp problem though...

Share this post


Link to post
Share on other sites

It just doesn't compute, if the engine just "suddenly" locked up then you should have direct metal to metal interference. If the carb really is clean and it has a new top end then you should take the time and check that the cams are correctly timed and that you have the proper amount of valve lash.

Be sure to check over the auto-decompression, like you implied, there could be a problem there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×