Jump to content
Sign in to follow this  

bike cuttin out

Recommended Posts

i have a 09 crf 450, it hasnt happend till recently when my bike gets hot it starts to bog when the thortle is more than half way open, then quits after i get off the bike and let it sit for a little bit. i've checked all fluid levels and they are fine, im assuming its a efi problem but cant be sure. anyone else encounter this? thanks

Share this post


Link to post
Share on other sites

The fuel filter in the fuel pump is clogged,this item is pretty easily replaceable,do a search and you will find a lot threads and explanation on how to change this item.

Share this post


Link to post
Share on other sites

I had the same problem with mine and the guy above me is right. Absolutely your fuel filter. Good luck.

Share this post


Link to post
Share on other sites

how could a fuel filter or a ground be a problem if the bike runs awesome when the bike has not been ridin for like more then 20 min.

Share this post


Link to post
Share on other sites
how could a fuel filter or a ground be a problem if the bike runs awesome when the bike has not been ridin for like more then 20 min.

It'll be the filter bro, my friend had the same problem and filter was full of crap, I was injured so pulled mine out for the hell of it, found it to be full of crap as well but still ran ok, its now part of my maintainence schedule.

Heres the thread with all you need to know. Have a look bet its black.

Think its something to do with not enough gas getting through to pressurize the line once initial pressure has dropped off = pop and stall.

Get in there!

http://www.thumpertalk.com/forum/showthread.php?t=847214&highlight=fuel+pump+09

Share this post


Link to post
Share on other sites

I had the same problem. It would cut out even after I let it cool down. It was really weird, but I rode for 3 hrs or so that day before it started cutting out. Then, it just instantly started cutting out. I decided to try the fuel pump filter(i figured cheapest place to start). It cured it. I actually just finished putting it in this morning. The bike is reving out perfectly again.

Share this post


Link to post
Share on other sites

Honda makes a filter replacement kit. It cost me $35. It'll need to be replaced whether a new filter fixes your problem or not. I'd be willing to bet that if your bike is at least 8 months old or so that your filter is pretty black.

P.S. Just in case, I ordered new o-rings too. But the kit did come with new o-rings. So now I've got extras I guess. :thumbsup:

Share this post


Link to post
Share on other sites

I'm sorry to keep chiming in but it dawned on me that I still have the wrappers with the part #s on them. Just in case anyone needs them:

Fuel filter kit (mine came with o-rings as well):

Part # 06160-MEN-A30

Extra O-rings:

Part # 16712-MEN-A30

16711-MEN-A30

Hope this helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×