Jump to content
Sign in to follow this  

I give up XR80 wont stay running. Max idle and dies

Recommended Posts

I've read and read, but can not come up with an answer. I have a 90 xr 80 and it seems to run fine when I first start it up. As it warms up it will no longer run correctly. it just dies. I have taken the entire carb apart multiple times to clean it. I have replaced the points and still no dice. I was going to try an e-bay carb just to see if thats my issue. They are only $29. I do have an xr100 but its a 94. Can I just swap the carb out for testing purposes?

Share this post


Link to post
Share on other sites

The 100 carb won't help. Check the entire intake system. The filter, boot and air holes. Be sure they are clean. Check for a plugged hose on the carb. I would check the pilot jet real good again. It you are not removing all of the dirt, it can keep getting clogged. It sounds like a fuel mixture problem to me. I have had to clean carbs multiple times myself. I don't know why, but I wasn't getting them clean.

Share this post


Link to post
Share on other sites

Either a partially plugged pilot jet or a vent problem, like a clogged gas cap vent.

Share this post


Link to post
Share on other sites

good calls..I ill try taking out the filter and gas cap and see how she runs. I didn't even think about those. I did take the screen out of the filter and put a new filter cover on.

Share this post


Link to post
Share on other sites

Ok I know this is going to sound strange, but I took off the gas cap air filter cover, airfilter and seat and she seems to run pretty good. I put the gas cap back on and no change. I put the air filter back on and seems no change. I put the air filter cover back on and I could hear a distinct difference in idle. When I put the seat back on she still ran but started to bog. I've never heard of a seat causing a bike to bog. Anyone ever heard of that?

Share this post


Link to post
Share on other sites

Hahaha! No! Is the air filter clean? If it's dirty or oil saturated, then it's having a hard time breathing.

What's the plug look like? The plug can answer questions sometimes.

Share this post


Link to post
Share on other sites

The air filter should be fine. I cut the screen out and got a pre-oiled filter from Iron Pony to slide over it. The top of the air box is broken a bit. I just thought it was strange.

Share this post


Link to post
Share on other sites

Sounds like the space between the top of the airbox and the seat might be restricting airflow, but I can't imagine how. Take a good look and see if maybe the seat pan is crushed down onto the airbox. The airbox being broken may be your clue and a good starting point, they don't usually break.

Share this post


Link to post
Share on other sites

Try it with the airboot off, try the other carb, low out the pilot. Afer that I would be looking into a CDI/points swap.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×