Jump to content
Sign in to follow this  

Need help with Lifan engine swap wiring

Recommended Posts

I put a 200cc Lifan 163fml-2 in a 87 TRX125. This was not a direct replacement but making it fit was no big deal. Everything is jam-up ready to go, rear brake lever is now a clutch, took both shifters to make one that would clear the foot peg, and had to remove the part of the frame that the airbox mounts to in order to fabricate an upper engine mount. Here's the problem. As most of you that have experience with Lifan engines know, wiring diagrams are hard to find and vary differently based on engine size and application. I need the diagram for the 163 FML-2 specifically. Hoopers has many posted but not the one I need. I believe this engine has a clutch safety switch and I would like to bypass it. I have everything working except the coil won't fire. I'm going to finish with a dumb question; Do any of you think this engine requires a good battery in order to run? The battery I have is weak and I have been using my charger to make power.

Share this post


Link to post
Share on other sites

NO PROBLEM MY FRIEND. Here it is. You need to be creative but this is how to hook up. Also, here is my thread where i did it personally.

This one is when you have a battery or lighting system and need output power. NOT NECESSARY.

200_wiring.jpg

This one is for RUNNNING ONLY.

200_Wiring_Edited.jpg

And my thread is here with some real life pictures.

http://www.thumpertalk.com/forum/showthread.php?t=847692

Good luck

-BIG DAN:thumbsup:

Share this post


Link to post
Share on other sites

SRAD, Bro, thank you very much! Everything works but I somehow have got something wrong, I just don't know what yet. When I hit the starter, the engine fires for the first 4 strokes then quits. With the use of a meter I learned that the spark gets weaker from the first stroke to the point that there is no fire at all on the 5th. Really very puzzling but again, thank you for the help and any input to this issue would be great. Never in my life have I had an issue like this and can't seem to find anyone who has.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×