Jump to content
Sign in to follow this  

xr50 throttle cable help

Recommended Posts

i recently snapped my stock throttle cable on my 2000 xr50r and i ordered on online and its deffinetly the wrong one i put it on and it revvs almost full throttle when it should be idling DOES ANYONE KNOW WHERE I CANT ORDER ONE? im in canada im soo pissed its soo hard to find a place that will send me a longer aftermarket throttle cable and carb cap for the stock carb SOMEONE HELP please

Share this post


Link to post
Share on other sites

The slide goes into the carb 2 ways, one way makes it hold the throttle half open, the otherway makes it slide in properly.. Check that I bet it's your problem!!

Share this post


Link to post
Share on other sites

on the thing with the needle on the end that slides into the carb there is a angled side does that angled part of the sleeve face the back of the bike or the front could u tell from that because i have the angled part facing the back

Share this post


Link to post
Share on other sites

I'm not sure off the top of my head

but it's a common mistake people make, just unscrew the top cap and spin the slide 90 degrees

Share this post


Link to post
Share on other sites

The bevelled edge of the throttle slide goes to the back side of the carb.

Make sure the throttle tube end of the cable is threaded all the way into the assembly, giving you more inner cable at the throttle slide end.

Share this post


Link to post
Share on other sites

Are you using a BBR cable? I have used a few of them, and they don't allow much slack. I have to back off the adjusters almost completely.

The beveled side of the slide should go towards the air cleaner.

Share this post


Link to post
Share on other sites

no its a FTP one i believe Fast trails performance all my settings are backed of max and the beveled end is facing the rear or facing the airbox yea

still an issue

Share this post


Link to post
Share on other sites

and one have pics or ideas it really bugs me cause riding and shifting my bike with it revving so high is bad news

Share this post


Link to post
Share on other sites

As long as you are 100% certain you have it assembled correctly and the adjusters backed off completely, there has to be something wrong with the length of your new cable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×