Jump to content
Sign in to follow this  

My Denver carb's got me flustered

Recommended Posts

Hoping Eddie reads this

Installed my Fcr from OTD and having some issues

Bike is 08 Sm Rs-3 open

800 altitude

3x3, emn

155 main

Bike starts well but has small pop ever 5 seconds even when warming up with choke on. Have adjusted screw from 2-3 turns slowly, making no difference.

Ordering a fuel screw today. But it's when I'm driving is what sucks. Throttle closed, it never backfires on decel, seems to have a slight hanging idle, even with air screw at almost three turns. Any time, any gear when I start back on the throttle I get a dead spot right away when I touch the throttle, usually a single low sounding pop. Carb runs great after in cleans up throughout range up to full throttle. At traffic lights if you gentle "twist twist twist" to get going, I get all kinds of pops and power loss, won't stall but sounds like crap.

I'm going over the bike today to verify no air leaks and will likely pull the carb to check fuel screw setting.

Could this be a squirt timing thing, I don't want to play with your shops settings if it turns out to be something else, wire mod is still entact, just that 1/8 throttle pop thats wrecking my riding. One more bit of info, it didn't seems to act like this when I first installed carb, instant response and first hour of riding was great, shut it off and restarted 2 minutes later will above concerns. Just can't figure out what changed. never added fuel in between.

thanks

thanks

Edited by Firedawg1998
added to text

Share this post


Link to post
Share on other sites

sound sliek it has a air leak or the pilot jet has some junk in it.

is the carb where you bought the carb only or was this a complete kit?

Share this post


Link to post
Share on other sites

I purchased just the carb I guess, I bolted on my sudco adapter, dropped in my emn. Your shop did the wire mod, so i just assumed set the squirt and whatever else is Drz required. Idles right around 1800. Arrived with fuel screw at 1 turn out, I started at 2.

Is wd40 good for airleak checks, i don't want to get any carb cleaner spray on the rest of my bike.

Share this post


Link to post
Share on other sites

I just when out and checked the clamps, all good , reset the fuel screw to 2.25, fired right up without choke, touched the choke and wants to die. ran great when cold, blip the throttle lightly and great response, no hesitation, 4 minutes later, blip the throttle same as before and am getting the sputter and hesitation, no hanging idle though. this is under light throttle twists. am puzzled..

Share this post


Link to post
Share on other sites

thanks for the help Eddie

turned out I adjusted my needle down one to position 4 and 100 percent of the popping on gear changes went away, found that it "hunted " alittle when cruising so I "half a clip width" shimmed it so I'm at 4.5 an it runs amazing. 2.25 on the fuel screw. My bsr had to be run on clip five with the JD kit to make it smooth when cruising, so it's all good. Had me really worried there, but what a nice noticible different in throttle response.

Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×