Jump to content
Sign in to follow this  

spongy clutch?

Recommended Posts

the clutch pull on my 2010 has a very spongy feel to it, i lubed it and still is no better...it even makes a horroble sound down were it goes into the motor...any ideas? any help is much appriciated

Share this post


Link to post
Share on other sites

Mine too. I got and 08 cable and bracket and converted it to the old cable route. The 10 cable makes too many turns and feels like crap real fast.

Share this post


Link to post
Share on other sites

so how do you do that? and has it fixed the problem completly?

Share this post


Link to post
Share on other sites

08 cable 08 bracket on the left cover like it is on all of the 09 and back 250's. The acturator has to have the weld ground off then welded back like the older crf's. The cable is routed the old way and the pull is easy and all of the flex in the 2010 setup is gone.

Share this post


Link to post
Share on other sites

so what i need to buy is an 08 cable and bracket and im good? it will fit perfectly on my 2010? no problems?

Share this post


Link to post
Share on other sites

The arm that the cable is connected to has to be modified. I ground the weld and moved it to the position of the 08 crf and rewelded it. Where in MD are you?

Share this post


Link to post
Share on other sites

hmm sounds like a pain...ill probably just buy a couple cables and just change them when they get like this...its not hurting anything right? or is it? and im from mount airy maryland...Frederick County

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×