Jump to content

08' 450f bogg problem


Recommended Posts

Ok, here's the deal. I've been working on my buddies bike and I went to put some gas in it and it leaked all over the floor. So I went and adjusted the float bowl a bit so it wouldn't leak. Then I went ahead and stared kicking it over a few times and finally after about 2 min it started but sounded horrible. I had to keep giving it gas and it wouldn't idle and it sounds like a valve might have been stuck. So I took the valve cover off and cranked it over a few times to make sure, and it seemed like they were fine. especially since it's on 08. So my guess now is that it's that something is wrong in the throttle body or the choke is stuck but it didn't seem like it to me. Has anyone else had this problem with the 08's. It sounded pretty bad and not like a throttle body problem, but I might be wrong.

Link to comment
Share on other sites

I'm no expert like some here, but I wouldn't think a valve because that would either bend the valve from piston contact or screw the cam from the valve not moving. I also think a valve wouldn't cause gas to flow from the carb. So, it seems that the problem is still carb related.

I hope someone else will come in with some insight but I'm thinking the carb has a stuck float or perhaps the pilot jet has come loose.

BubZ

Link to comment
Share on other sites

The float level adjustment was probably never the cause of the fuel overflow. Float level isn't something that changes significantly over time. The cause was much more likely either a dried out or dirty needle/seat.

I have had this to happen to me on a DRZ 125 a year ago. Just as gray said. The rubber o-ring that was under the needle had dry rotted and cracked and caused the carb to just fill with gas. replaced the ring and it was fine.

Link to comment
Share on other sites

  • 3 weeks later...

I got it running but it still runs like crap.

I cleaned the carb pretty good with some cleaner and the main squirter was clogged. Now it squirts when I twist the throttle and it runs but it not running very good like something else might be wrong with it. Because come to find out the water pump seal and pin and it filled up the engine case with coolant till oil and water went through the head and down out of the valve cover breather.

So right away I put in new seals and pin for the water pump drained the motor of oil/coolant. But no telling how long my buddy rode it and let it do some damage? The carbs are clean now and it idles rough and backfires like hell but when its on the throttle it goes really good. But as soon as you let off the gas it doesn't sound like a smooth return to idle. It's almost like it's binding up like maybe the cams are freezing up slowing it down.

I don't know if they are bad or not because I looked at them but maybe I should take them out completely and check.

Anyways maybe its just me and these carb's make the bike act like that when something is wrong. It also might have an air leak causing it to have a high idle sometimes. Could it just be the carbs? I sure hope so.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...