Jump to content
Sign in to follow this  

rough running yz250

Recommended Posts

Fired my 05 yz250 up for the 1st time in a few months,it started on 3rd kick(happy about that since sometimes I had to tow start the 4 strokes after the winter).It runs crappy up to the powerband where it seems to takeoff and run okay.What should I try 1st second ect to get it to run correctly,betting its the corn gas, though I always buy the highest octane the gas station sells,they put the methanol in high test to right.

Share this post


Link to post
Share on other sites
Fired my 05 yz250 up for the 1st time in a few months,it started on 3rd kick(happy about that since sometimes I had to tow start the 4 strokes after the winter).It runs crappy up to the powerband where it seems to takeoff and run okay.What should I try 1st second ect to get it to run correctly,betting its the corn gas, though I always buy the highest octane the gas station sells,they put the methanol in high test to right.

Was it stored with gas in the carb? If so the carb may be gummed up from deposits. I'd try giving the carb and jets a good cleaning.

Also, is the gas in it now fresh or left over as well?

Share this post


Link to post
Share on other sites

it was probably loaded up as well. When i fired my bike up after its beed sitting for a whil, it smokes a lot and is loaded up. So let it warm up for a couple mins, then ride it and clear it out. But like stated, clean th ecarb, all jets etc. Use some fresh fuel, clean the air-filter, oil and your good to go:thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...