Jump to content

did I kill my relay?


Recommended Posts

I bought a 98 dr650 2 weeks ago and to pass inspection the horn needs to work. I found the problem; the switch in the relay was dirty. I disassembled the relay and sprayed it down with sensor safe TB cleaner thinking it would work with electrical connections. It fixed the horn but now the turn signals are all screwed up. The right rear bulb doesnt do anything when I use the right signal, and the 2 front and left rear light up when I use the left signal. Will the signals work again when the TB spray dries up off the relay or was the TB spray just a really stupid idea and now i'm screwed. 👍🤣 - thanks

Link to comment
Share on other sites

Check/replace the right rear bulb.

Buy a 2 prong Heavy Duty flasher from any auto parts store for $5 and mount it with a zip tie.

I have them on all on my bikes and they work fine.

I refuse to pay Suzuki $40-$50 for a flasher relay. 👍

hey bob would that be the same too for a dr350s?????

Link to comment
Share on other sites

I pulled the rear bulb that wasn't working and switched it with the other side. The problem was inverted so I replaced the bulb and now it works again.👍 the relay is OK for now. It is pretty strange how the bulb died right after I sprayed the relay...

I'll make sure to pick up some of the blinker safe TB cleaner for next time, they were out of it and all they had was blinker fluid...

-thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...