Jump to content

Not starting, need help!


Recommended Posts

I have a 96 XR650L and I just got done completely re-building it. My countershaft was bad so I swapped it out with a new XR600R shaft, put in the NX650 2nd gear and also added a kickstart. I also got rid of the stock cam and switched to a hotcam...My problem is that I can't seem to get the bike to have enough battery juice to turn the engine over. I can't even use the kickstarter to turn it over. I got it running today for about 2 minutes but I can't get it running anymore. I am thinking that since I switched cams and had to get rid of the auto-decompression device that it is harder than hell to start now. Does that make sense?? If so, how in the heck do I fix it so that I can actually start it?????? This thing is driving me nuts! All I wanna do is get it done so I can finally ride it. Thanks guys!!

Link to comment
Share on other sites

I have a 96 XR650L and I just got done completely re-building it. My countershaft was bad so I swapped it out with a new XR600R shaft, put in the NX650 2nd gear and also added a kickstart. I also got rid of the stock cam and switched to a hotcam...My problem is that I can't seem to get the bike to have enough battery juice to turn the engine over. I can't even use the kickstarter to turn it over. I got it running today for about 2 minutes but I can't get it running anymore. I am thinking that since I switched cams and had to get rid of the auto-decompression device that it is harder than hell to start now. Does that make sense?? If so, how in the heck do I fix it so that I can actually start it?????? This thing is driving me nuts! All I wanna do is get it done so I can finally ride it. Thanks guys!!

Joel,,if it`s not cranking over fast enough and you have a high comp piston,you`ll need a higher cranking amp battery..stock is only 120 amps..i`m getting another battery because of the same problem,mine will start,but cranks hard...a YTZ14S battery has 230 cold cranking amps..and it`ll spin her over no problem..it`s 3/8 inch taller and will fit,but the battery holder will need to be rebent at the top for fit....

Hey,,did you try any of the CDI`s i fixed for ya....

Brian

Link to comment
Share on other sites

Well, I'm not sure if its the battery or not. I have had the 103mm high comp piston for a while and before the rebuild it was never a problem. I think it has something to do with the hotcam that I just added because it does not use the auto-decompressor thing. I can stand on the kickstarter and it doesn't even budge. Its almost like something is caught or something. AAAAHHHHHHH, I just want to ride my damn bike again!! Its been about 7 months!!

Haven't gotten a chance to try any of the CDI's yet, but I will as soon as I get the bike going.

Link to comment
Share on other sites

Well, I'm not sure if its the battery or not. I have had the 103mm high comp piston for a while and before the rebuild it was never a problem. I think it has something to do with the hotcam that I just added because it does not use the auto-decompressor thing. I can stand on the kickstarter and it doesn't even budge. Its almost like something is caught or something. AAAAHHHHHHH, I just want to ride my damn bike again!! Its been about 7 months!!

Haven't gotten a chance to try any of the CDI's yet, but I will as soon as I get the bike going.

Ok,,so pull the spark plug,,if it rolls over easy with the plug out,and no noise,,then it`s compression causing the problem...and if that`s the problem then you need to get a Webcam that can use the auto-decompression assembly,,or change the valve cover so a manual decomp can be used...but a higher amp battery is likely going to turn her over...as it sits now...

B

Link to comment
Share on other sites

I got you on ADV too..👍🤣:lol:

if it turns over hard you`ve got a binding interference issue,,if it turns over easy then it`s a high compression issue,,either put the old cam back in,or the YTZ14S battery,,,,or get a webcam as the webcam will use the decomp assembly...

it won`t start of course if the plugs is out,,you just want to know if the engine is capable of turning..you can pull the round crank cover with the plug out and turn it over counterclockwise with a 17mm socket too if you like..

Oh,,thanks again for the CDI...it`ll be nice/reassuring to have a spare out on the trail..

B

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...