Jump to content
Sign in to follow this  

Coolant

Recommended Posts

Just repaired a -05 ktm 400 exc motor. Everything seems to be OK motor works great but there is one weird thing. Green coolant is grey when take it out. I have took it out couple of times...every time same thing, dark gray colour coolant.👍 It is not oil and motor oil seems good and clear. Water pump seals have been replaced. What's the problem? What makes that dark grey colour? By the way this was the first coolant change.

Thanks in advance:thumbsup:

Jusa

Share this post


Link to post
Share on other sites

Interesting question. The dye does fade with time and contamination will change the color the coolant. I've just never paid much attention to color when draing coolant but grey is not far from faded green in color.

Share this post


Link to post
Share on other sites

I would fluch the system out with fresh clean water a few times and then reinstall some OEM antifreeze.

Share this post


Link to post
Share on other sites

I have tried to wash the system couple of times but there is still that weird colour exist. The cooling system have been dry during this repair procedure about a week. And when put a new coolant into system it takes some dry impurity from the radiator walls or there is a bad head gasget.

Share this post


Link to post
Share on other sites

Try draining the coolant, filling with 50/50 water/vinegar, running the bike until hot, then draining the water/vinegar, repeat until it comes out clear, repeat with plain water, then refill with coolant.

Share this post


Link to post
Share on other sites

What does the vinegar do in the system?

Share this post


Link to post
Share on other sites

Vinegar is a mild acid and will acid clean your cooling system. I've used vinegar with hot water to acid clean metals but it seems a bit severe to me for a bike cooling system.

Share this post


Link to post
Share on other sites
50/50 vinegar isn't too bad, really, just be sure to flush it thoroughly. Is there any chance this bike has a bad head gasket? Ever leaked oil into the system?

Coolant was green when I took it out before service. No leaks before and now there are new water pump seals and new head gasket. Head is fully serviced and cleaned.

I checked the coolant yesterday and it wasn't so bad anymore. I have flushed it 5 times.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...