WR 450 Charge/lighting Problems.

Hi all!

I have a problem that is doing my head in! It is a long story but stay with me! Many other threads I have read cover bits and pieces of my problems but none have fixed it. Here goes!

I have an '06 wr 450. My battery seemed to be getting down (after 3 years- it's a stock yuassa) so I kick started to get going. While out riding, at low revs, it would carry on popping and stalling and as it turned out, the battery was so flat the bike hardly ran down low, but kept going all the same. We came to a stop for a break, but when I went to leave, I had no dash lights, starter or anything. A couple of kicks later and it fired so I rode it home and put it on charge and the next day all was normal (dash, electric leg ect).

Time to follow the manual and it's testing procedure.

With the bike running, I had no headlight and no charge, checked everything as per instructions and it seemed to be the regulator/rectifier, so I replaced it with a new (genuine) one much to the delight of the local supplier who told me this would fix the problem.... It did not. Took it for a ride, same problems. Kick started fine and rode home. Tested every thing again, resistance tested the stator and so on.

This is what i've come up with. Sometimes the problem is gone and other times it is there. Somtimes when it will not charge or run lights, I can give it some big revs and it comes back to life! Bash it over a jump or two and out they go again. (i had the multi meter strapped to the bars!)

I tested the output of the two stator outputs while hooked up and they were low (like 11-12v) and they actually dropped a bit with revs, so I un-plugged them and there was around 50vac each.

I'm at a loss and feel like putting a match to it!!! Any help appreciated. :thumbsup:

My first guess would have been the reg/rec as well, but you replaced that. Is the stator stock or aftermarket or rewound? This could very possibly also just be a loose connection in the wiring as well. Sometimes it's definitely worth just having a good shop look it over, definitely before taking a match to it.

sounds like a loose connection to me.

It does to me too but I have unplugged and checked everything I can see. I was thinking bad earth but all I see is a common earth plug behiend the headlight mask so I ran a seperate earth to it but to no avail. Maybe a short? I don't know.... Oh and the coil is stock. I have never touched it as I only ride in the day time. Is it possible that the two seperate windings are shorting together (or is it likley?) as I loose both lights and charge at the same time? Thanks for the responses.

Edited by timare

I have the Trailtech setup, which runs all power (ignition and battery charge) through the battery. In that setup, the bike gets its spark from the battery and all lights run through the battery. I believe the stocker gets its spark from the battery. I had run into a problem at one time where I goofed up the wiring on the Trailtech reg/rec and the battery was not getting enough charge, leading to flickering lights (HID) and then the engine sputtering because there was not getting enough power (via my bad wiring job) to keep the battery with enough charge. Kind of the same, but you have a different system as it's stock.

If you are losing both lights (ac) and charge to the battery (dc) at the same time, and have already replaced the reg/rec with another stock unit, this would lead me to believe that your problem is stator related or again a connection problem between stator and reg/rec or reg/rec and whatever is downstream. You have verified that you stator is good so we're back to the connection issue. Make sense? This is not a battery issue as the stock lighting should still work fine with a battery that is shot or a good one as the lights on your bike run off ac.

I am by no means an electrician, so this is just my .02, but everything you've said would lead me to this being more a connection problem than anything else. And bad connections are a bitch to find sometimes, but fortunately we're talking about a bike and not a house. Take a real good look at all the connections to and from that reg/rec. Unplug the plugs and plug them back together. I have already found plugs on my bike that will not stay together without a zip tie as the little locking tab does not work......and it looks like it is otherwise plugged together, but not making complete contact. Check fuses as well.

You're going to find it!

*** Edit- -you've already done a lot of unplugging and replugging by the sound of it. What about the various connections that are not directly related to the reg/rec? By that, if you had a loose connection up by the on/off button that basically affected the entire bike (lights/ignition/charge to the battery) this would likely produce some of the same symptoms you are experiencing. You had mentioned that lights cut out over jumps as well. And double check that plug that goes into the spark plug cap (coil). That is the one that I cannot get to stay together by itself.


Thanks OUTERLIMITS! I will check out all of the suggestions when I get a chance (I'm a shift worker). Thanks again for the replys, and hopefully I can sort it out without cracking out the wallet. It will be something so small but as yet i'm yet to see it. Maybe I will have to cut into the loom and check for broken wires/shorts, you know due to the jump landings shutting the lights and charge down (or even a mono for that matter). Till then, it looks like the KTM is coming out to play! Cheers.

just throwing this thought out, from a past head scratcher, on a lead acid battery from a truck I had a problem before that the plates in the battery broke free and would occasionally migrate and short against each other, killing the entire vehicle. when the vehicle would get towed home the plates would migrate back into position from the angle of the tow truck and would load test fine after a charge. not sure how that would relate too a gell filled battery that usually sets on its side but don't discount the thought until proven good.

I had the same problem on my 07 and it turned out to be a bad connection at the conector coming from the lead under the seat. I found it by jiggling with the bike running, everything was checking out with voltage tests.

Took a little piece of tinfoil to fix :thumbsup:

Thanks for the replys guys (and keep them coming!). I have had 2 different batterys on it now being my original Uassa and an aftermarket piece of rubbish that was returned twice, but I also have a brand new Uassa waiting to go on. I was going to fit it once the problem was solved but I might as well try it I guess. As for the lead under the seat jsantapau, was that a main battery lead or the earth lead heading up front? I will check them all out all the same. Thanks again for taking the time. Cheers guys:thumbsup:.

Well it seems I have finally fixed it! (I think anyway).... I kid you not, I was going to order a new stator tomorrow if I couldn't find a problem tonight as it keeps doing the same thing... Sometimes working, sometimes not. Well get this, the lights went off as soon as I left the shed so I turned around to test the stator while it was playing up and all tested well, but here is the thing - It wasn't even warm yet but there was a burning smell! The only hot thing was the pipe so along I went and there it was!!!! The back brake switch wire had worn through and was shorting on the exhaust pipe!!! Kill me now! I just hope that this rant can help someone with a similar problem take a much shorter time to fix it that me! Thanks to all who replied, and I'll update this if it fails again! Cheers from Oz.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now