Jump to content

kx 100 power valve stuck?


Recommended Posts

So I bought a cheap 2001 kx100 off a buddy he just rebuilt it and went over everything. Since he got it ran like crap and everyone told him it was this or that so after rebuilding the whole motor it still did it. Has no power on the bottom end and after your in the throttle for 5 to 10 seconds it then takes off like a rocket ship but as soon as you let the motor spoll down it starts all over again. I took the cover off for the power valve and you can watch it operate When you hold the throttle wide open it dosent move for 5 to 10 seconds then you can see it start to open up then it takes off. What could this be should I light it on fire.

Link to comment
Share on other sites

Take the cylinder off, something is wrong witht he powervalve. Wasnt put togerather correctly, or the gears on the powervalves are broke off or the gears on the actuating rtod are bad. Its the powervalve without a doubt.....

Link to comment
Share on other sites

  • 2 weeks later...

So let me boggle your minds after looking at teh power valve nothing everthing was fine so I buy a new motor expecting to find the problem nope acted exactly the same so It has to be the electronics I say. I had to switch the magneto to the new motor the exact way I took it off so I open it back up clocked the timing completly the other way and shazam Its like a rocket ship so Now I have a spare motor.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...