Jump to content
Sign in to follow this  

950sm bog/miss part throttle

Recommended Posts

Hey guys I am posting for a friend. He just recently bought a 2007 950 supermoto. He has put around 600 miles on it and it recently developed a bog/hesitation when rolling into the throttle say in third gear at lower mid range RPMS. if you snap the throttle it falls on its face. It idles/starts and cruises fine. and but when a load is put on without dropping a gear it starts to sputter.

no backfiring or poping from the carb. The problem seems to get a little better when the choke is on, though not much. I was thinking it sounds like an accelerator pump issue?

I am also not even sure fo how the carb or carbs are set up in this LC8.

thanks, will

Share this post


Link to post
Share on other sites

I agree that they are jetted lean but this is a new problem and it seems to be getting worse. I actually gonna get the akrapovic full exhaust the end of this month! and of course I was gonna re-jet then.

thanks, will

Share this post


Link to post
Share on other sites

If it gets better with the choke on then you might have clogged pilot jets. Gas these days is crap and breaks down quickly.

Share this post


Link to post
Share on other sites

Believe me, it is lean as heck to meet epa emmisions.

Get a jet kit and it will run 10 times better.

I have an 06 an di installed the Hes2wind kit, You can find him on ADVRider.com. He know the LC8 well.

Share this post


Link to post
Share on other sites

which carb kit fro factory pro should i get? any ideas on what to start with as far as jetting with stock everything?

will

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...