Jump to content
Sign in to follow this  

TT drz400sm fcr problems.

Recommended Posts

I really didn't want to start a new thread but I can't find the exact carb problems I'm having.

I bought a TT 39mm fcr a month ago and finally got to put it on.

2006 drz400sm

full yoshi rs2

3by3

TT air screw

sea level

Initially it ran good but had an awful bog when you snapped the throttle from idle. From the little carb experience I have it seemed like a clogged pilot jet. I tore the entire carb apart, every single part came out and was cleaned with 2+2. I then adjusted the float using my clymer manual, it was a bit off so I thought that was the problem.

Now it runs ten times worse.

Idle is unstable

pops and backfires like crazy

still cuts out when throttle is snapped from idle

brand new plug is black with carbon build up

seems to run better with choke on

It ran good with stock carb. What did I do to my poor bike. Please help.

Share this post


Link to post
Share on other sites
I then adjusted the float using my clymer manual, it was a bit off so I thought that was the problem.

i doubt it was off.

did you take the slide out of the carb?

what jetting did you use? removed the pilot air jet? o-ring or wire mod?

Share this post


Link to post
Share on other sites

TT jetting, left it just how it came.

I did take the slide out to clean it.

What do you set the float at?

Not sure what o-ring or wire mod is.

Thanks

Share this post


Link to post
Share on other sites
TT jetting, left it just how it came.

I did take the slide out to clean it.

What do you set the float at?

Not sure what o-ring or wire mod is.

Thanks

as they come is not the correct jetting.

follow the link in the above post. its a kit.

slide plate goes square end down.

float level is set at 9mm with the arm just touching the needle plunger but not compressing it.

Share this post


Link to post
Share on other sites

I bought this kit from Thumper Talk a month ago.

- 200 Main Air Jet

- 160 Main Jet

- 45 Pilot Jet

- 100 Pliot Air Jet

- EMR Needle 3rd position from top, or flat end

I followed the directions it came with and easily installed it.

Not sure what you mean about it not coming with the correct jetting, I thought it did.

Hopefully I put the slide plate in wrong. I used my book to put it back together though. Who knows? I was in a hurry because I just want to ride the stupid thing.

Besides checking the slide plate I don't know where to go from here.

Edited by detdtim

Share this post


Link to post
Share on other sites
Not sure what you mean about it not coming with the correct jetting, I thought it did.

one more time. its a kit. it comes with the parts. you must install them and set the rest of the jetting.

noteably installing the EMN needle,removing the pilot air jet and doing the o-ring/wire mod.

Share this post


Link to post
Share on other sites

I did everything the directions told me to the first time I put it on.

I don't have the directions in front of me, but I really don't remember reading anything about the o-ring/wire mod. It doesn't sound familiar to me at all.

I've searched for the o-ring/wire mod and can't find anything. Could you please direct me towards this information.

Thanks a bunch.

Share this post


Link to post
Share on other sites
I've searched for the o-ring/wire mod and can't find anything. Could you please direct me towards this information.

Thanks a bunch.

You didn't look up on the page of Intake - Jetting / Fuel Injection , look at the sticky and you 'll se the o-ring mod .

As for the directions these witch came with the carb are not the corect ones , look at the link above :thumbsup:

Share this post


Link to post
Share on other sites

I was finally able to do some work on my bike.

I did have the slide plate upside down. My Clymber manual has a schematic of the carb with each part numbered. On that schematic it shows the flat end of the slide plate up. That's why I had it in wrong.

This is the jetting I have now. Everything the directions tell you to do. I also did the o-ring mod.

- 200 Main Air Jet

- 160 Main Jet

- 45 Pilot Jet

- 100 Pilot Air Jet (removed)

- EMR Needle 3rd position from top, or flat end

sea level

The bike runs good except when you snap the throttle. It bogs very bad. If I pull out the choke just a little it seems to stop. It does it at any rpm, not just from idle. I'm thinking the pilot jet is lean.

What do you guys think?

Thanks

Share this post


Link to post
Share on other sites
needs to have the EMN needle that came in the kit.not the EMR.

the directions clearly say this.

I do have the EMN needle installed. I just copied and pasted that jetting from another thread and missed that is was wrong.

Share this post


Link to post
Share on other sites
you are riding the bike while doing all testing correct?

Yes I am riding the bike. It runs good except for it cutting out if you snap the throttle. It cuts out at any rpm. It pops a little on deceleration but not too bad.

Its not just a little bit either. Its kind of hard to pull out with out stalling. I grew up riding two strokes so I won't be able to live with even a little bog.

It seems like it gets better the farther out I turn the air screw and worse when I put it in. I'm going to try a 50 pilot and see what happens.

It also seems to get worse when I turn in the ap timing screw. I tried it from all the way out to all the way in. I have it all the way out now.

What do you think? Thanks.

Share this post


Link to post
Share on other sites

its not the pilot circuit.you will just make it idle rich.its a fuel screw.not a air screw.

remove the o-ring and wire the linkage solid.the timing screw needs to be a half turn it from where it was stock.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×