Jump to content

Exhaust pop and flame during hot starting


Recommended Posts

I have a 2006 450x. Air box cut. JD Jet kit installed. Stock exhaust will baffle out. The bike starts great when cold and runs fantastic. I am having a problem when I stop and wait for people to catch up with big red machine. It will turn over and will make a load "pop or bang" out the exhaust.I do not use the hot start lever. One of the guys said he saw flames. What could be causing this?

Thanks

Link to comment
Share on other sites

This sounds like one of those things that can have 10 different causes producing this one effect. To get the help you are looking for I'm gonna suggest supplying a bit more info.

JD kit installed. Did this problem happen after you installed the kit or was everything working fine and just recently changed.

What are your jetting specs.

I'm not the expert, but I thought a rich pilot setting would cause this. Hopefully, you'll hear from the experts soon. Good luck.

Link to comment
Share on other sites

Have you checked the valves?

I have an '06 with the same mods. I have never used the hot start and when hot it starts in what seems like a single rotation of the starter - to compare, a brand new EFI car takes longer to fire up than my X when hot. I spent a lot of time getting thing just so but once dialed in, it starts immediately.

I do have an AM filter and backfire screen removed.

+1 to Krannie, no throttle on restart. Clutch in and hit the button.

Link to comment
Share on other sites

I forget what jet I put in.Just followed the kits instructions. I don't know if it did it before installing the JD kit because I did it before I ever rode it in the bush. I have never used the hot start but I will try that next week-end.I will also let it idle a bit before shutting off. Thanks for the input.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...