Jump to content

YFZR oil/gas problems


Recommended Posts

I have a 2009 YFZ450R, just had the engine rebuilt with a trinity 480 bb kit, put '06 cams in it and did the cam mod to the exhaust cam, also put a new oil pump in. Since it has been rebuilt, I have ran 5 tanks of gas through it to break it in but yesterday I took it out to my local MX track and rode it hard for the first time, at first everything was good, I'd go out and do 3 or 4 laps then come in and cool down with no troubles. then towards the end of the day I came in and after the machine sat for a while, oil started dripping out the airbox drain and it smelled like gas. This is not cool, I just put $2,200 into the rebuild, I want to take it in to the shop but first I'd like to get an idea of what's going on. Any input is greatly appreciated!

Link to comment
Share on other sites

OK, what mods did the shop do other than big bore kit? If they did not install some kind of power inhancer for the fuel system then there is your problem. Possible leaned it out and took out the rings creating excessive blow-by...

Link to comment
Share on other sites

Yea, I have a HMF efi optimizer but it kinda ran a little funny with it, I didnt think anything of it...I'll take it in and see what the deal is, if I need new rings and such then buy a PCV with an auto tune and hopefully that will do it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...